Every CVE Search/ Get API key

CVE-2002-0970

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints...

7.5 HighFix available

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack.

Exploit likelihood

2.84%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack.

Record
CVE-2002-0970
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack.

Record
CVE-2002-0970
Updated
2026-11-02
EUVDEUVD-2002-0959 No score

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack.

Record
EUVD-2002-0959
Updated
2026-11-03
GitHub AdvisoriesGHSA-x288-6jm2-5j5c No score

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints...

The SSL capability for Konqueror in KDE 3.0.2 and earlier does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack.

Record
GHSA-x288-6jm2-5j5c
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kdelibs
Debian:3.0
before 2.2.2-13.woody.2
2.2.2-13.woody.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-0970 is a high vulnerability (CVSS 7.5) in Kde, published August 17, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.84%, the 86th percentile. Fixed in kdelibs 2.2.2-13.woody.2.

References

Show 6 moreShow less
MoveEnter Open