Every CVE Search/ Get API key

CVE-2008-0983

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size...

5.0 MediumFix available

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Exploit likelihood

2.31%Down 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Record
CVE-2008-0983
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Record
CVE-2008-0983
Updated
2026-11-02
EUVDEUVD-2008-0990 No score

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Record
EUVD-2008-0990
Updated
2026-11-03
GitHub AdvisoriesGHSA-fxrf-v868-58jw No score

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size...

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Record
GHSA-fxrf-v868-58jw
Updated
2026-11-02
OSV No score

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Record
CVE-2008-0983
Updated
2026-11-02
OSVDEBIAN-CVE-2008-0983 No score

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

Record
DEBIAN-CVE-2008-0983
Updated
2026-11-02
OSVopenSUSE-SU-2024:10585-1 No score

lighttpd-1.4.59-2.1 on GA media

These are all security issues fixed in the lighttpd-1.4.59-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10585-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lighttpd
Debian:12
before 1.4.18-2
1.4.18-2
lighttpd
Debian:13
before 1.4.18-2
1.4.18-2
lighttpd
Debian:14
before 1.4.18-2
1.4.18-2
lighttpd
Debian:4.0
before 1.4.13-4etch9, plus listed versions
1.4.13-41.4.13-4etch11.4.13-4etch21.4.13-4etch31.4.13-4etch4
Show 4 moreShow less
1.4.13-4etch51.4.13-4etch61.4.13-4etch71.4.13-4etch8
1.4.13-4etch9
lighttpd
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 1.4.59-2.1
1.4.59-2.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-0983 is a medium vulnerability (CVSS 5.0) in Lighttpd, published February 26, 2008. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.31%, the 83rd percentile. Fixed in lighttpd 1.4.18-2.

References

Show 22 moreShow less
MoveEnter Open