Every CVE Search/ Get API key

CVE-2007-3372

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via...

2.1 LowFix available

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Exploit likelihood

0.40%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Record
CVE-2007-3372
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Record
CVE-2007-3372
Updated
2026-11-02
EUVDEUVD-2007-3362 No score

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Record
EUVD-2007-3362
Updated
2026-11-03
GitHub AdvisoriesGHSA-w53f-m8p6-x7g6 No score

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via...

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Record
GHSA-w53f-m8p6-x7g6
Updated
2026-11-02
OSV No score

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Record
CVE-2007-3372
Updated
2026-11-02
OSVDEBIAN-CVE-2007-3372 No score

The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Record
DEBIAN-CVE-2007-3372
Updated
2026-11-02
OSVopenSUSE-SU-2024:10643-1 No score

avahi-0.8-7.2 on GA media

These are all security issues fixed in the avahi-0.8-7.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10643-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
avahi
Debian:12
before 0.6.20-2
0.6.20-2
avahi
Debian:13
before 0.6.20-2
0.6.20-2
avahi
Debian:14
before 0.6.20-2
0.6.20-2
avahi
Debian:4.0
From an advisory covering 2 CVEs
before 0.6.16-3etch2, plus listed versions
0.6.16-3etch1
0.6.16-3etch2
avahi
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 0.8-7.2
0.8-7.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
affected, aliases, facts, references, titleGitHub Advisories, OSV
first indexedCVE List, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2007-3372 is a low vulnerability (CVSS 2.1) in Avahi, published June 22, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in avahi 0.6.20-2.

References

Show 22 moreShow less
MoveEnter Open