Every CVE Search/ Get API key

CVE-2008-5621

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x...

6.0 MediumPublic exploitFix available

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Exploit likelihood

2.15%Down 28.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.0

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Record
CVE-2008-5621
CVSS 2.0
6.0 MediumAV:N/AC:M/Au:S/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Record
CVE-2008-5621
Updated
2026-11-02
EUVDEUVD-2008-5595 No score

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Record
EUVD-2008-5595
Updated
2026-11-03
GitHub AdvisoriesGHSA-427m-jx2h-q45m No score

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x...

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Record
GHSA-427m-jx2h-q45m
Weakness
CWE-352
Updated
2026-11-02
OSV No score

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Record
CVE-2008-5621
Updated
2026-11-02
OSVDEBIAN-CVE-2008-5621 No score

Cross-site request forgery (CSRF) vulnerability in phpMyAdmin 2.11.x before 2.11.9.4 and 3.x before 3.1.1.0 allows remote attackers to perform unauthorized actions as the administrator via a link or IMG tag to tbl_structure.php with a modified table parameter. NOTE: other unspecified pages are also reachable, but they have the same root cause. NOTE: this can be leveraged to conduct SQL injection attacks and execute arbitrary code.

Record
DEBIAN-CVE-2008-5621
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin
Debian:12
before 4:2.11.8.1-5
4:2.11.8.1-5
phpmyadmin
Debian:13
before 4:2.11.8.1-5
4:2.11.8.1-5
phpmyadmin
Debian:14
before 4:2.11.8.1-5
4:2.11.8.1-5
phpmyadmin
Debian:4.0
before 4:2.9.1.1-10, plus listed versions
4:2.9.1.1-34:2.9.1.1-44:2.9.1.1-54:2.9.1.1-64:2.9.1.1-74:2.9.1.1-84:2.9.1.1-9
4:2.9.1.1-10

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBphpMyAdmin 3.1.0 - Cross-Site Request Forgery / SQL Injection2008-12-08

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-5621 is a medium vulnerability (CVSS 6.0) in Phpmyadmin, published December 17, 2008. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in phpmyadmin 4:2.11.8.1-5.

References

Show 16 moreShow less
MoveEnter Open