CVE-2009-0544
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of...
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large ARC2 key length.
Exploit likelihood
What each source reports
NVD Score used
10.0
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large ARC2 key length.
- Record
CVE-2009-0544- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large ARC2 key length.
- Record
CVE-2009-0544- Updated
- 2026-11-02
EUVDEUVD-2009-0548 No score
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large ARC2 key length.
- Record
EUVD-2009-0548- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w9fp-w8cr-vgpg No score
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of...
Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large ARC2 key length.
- Record
GHSA-w9fp-w8cr-vgpg- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
python-cryptoDebian:5.0 |
before 2.0.1+dfsg1-2.3+lenny0, plus listed versions 2.0.1+dfsg1-2.3 |
2.0.1+dfsg1-2.3+lenny0 |
python-cryptoDebian:4.0 |
before 2.0.1+dfsg1-1.2+etch0, plus listed versions 2.0.1+dfsg1-1.2 |
2.0.1+dfsg1-1.2+etch0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PyCrypto ARC2 Module - Remote Buffer Overflow | 2009-02-07 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-0544 is a high vulnerability (CVSS 10.0) in Pycrypto Arc2, published February 12, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.5%, the 96th percentile. Fixed in python-crypto 2.0.1+dfsg1-2.3+lenny0.
References
mandriva.com/security/advisories?name=MDVSA-2009:050
exchange.xforce.ibmcloud.com/vulnerabilities/48617
gitweb2.dlitz.net?p=crypto/pycrypto-2.x.git%3Ba=commitdiff%3Bh=d1c4875e1f220652fe7ff8358f56dee3b2aba31b
mandriva.com/security/advisories?name=MDVSA-2009:049
openwall.com/lists/oss-security/2009/02/07/1
secunia.com/advisories/35065
Show 10 moreShow less
gitweb2.dlitz.net?p=crypto/pycrypto-2.x.git%3Ba=commitdiff%3Bh=fd73731dfad451a81056fbb01e09aa78ab82eb5d
secunia.com/advisories/34199
securityfocus.com/bid/33674
lists.opensuse.org/opensuse-security-announce/2009-05/msg00000.html
openwall.com/lists/oss-security/2009/02/12/5
gentoo.org/security/en/glsa/glsa-200903-11.xml
nvd.nist.gov/vuln/detail/CVE-2009-0544
gitweb2.dlitz.net?p=crypto/pycrypto-2.x.git;a=commitdiff;h=d1c4875e1f220652fe7ff8358f56dee3b2aba31b
gitweb2.dlitz.net?p=crypto/pycrypto-2.x.git;a=commitdiff;h=fd73731dfad451a81056fbb01e09aa78ab82eb5d
github.com/advisories/GHSA-w9fp-w8cr-vgpg