Every CVE Search/ Get API key

CVE-2009-0478

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to...

5.0 MediumPublic exploitFix available

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Exploit likelihood

72.0%Up 59.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Record
CVE-2009-0478
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Record
CVE-2009-0478
Updated
2026-11-02
EUVDEUVD-2009-0482 No score

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Record
EUVD-2009-0482
Updated
2026-11-03
GitHub AdvisoriesGHSA-cfw6-qxff-576v No score

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to...

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Record
GHSA-cfw6-qxff-576v
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Record
CVE-2009-0478
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0478 No score

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

Record
DEBIAN-CVE-2009-0478
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squid
Debian:12
before 2.7.STABLE3-4.1
2.7.STABLE3-4.1
squid
Debian:13
before 2.7.STABLE3-4.1
2.7.STABLE3-4.1
squid
Debian:14
before 2.7.STABLE3-4.1
2.7.STABLE3-4.1
squid3
Debian:4.0
before 3.0.PRE5-5+etch1, plus listed versions
3.0.PRE5-5
3.0.PRE5-5+etch1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBSquid < 3.1 5 - HTTP Version Number Parsing Denial of Service2009-02-09

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0478 is a medium vulnerability (CVSS 5.0) in Squid, published February 8, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 72.0%, the 99th percentile. Fixed in squid 2.7.STABLE3-4.1.

References

Show 9 moreShow less
MoveEnter Open