Every CVE Search/ Get API key

CVE-2009-0751

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and...

5.0 MediumPublic exploitFix available

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Exploit likelihood

10.4%Up 3.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Record
CVE-2009-0751
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Record
CVE-2009-0751
Updated
2026-11-02
EUVDEUVD-2009-0751 No score

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Record
EUVD-2009-0751
Updated
2026-11-03
GitHub AdvisoriesGHSA-9574-q3cv-v9f8 No score

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and...

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Record
GHSA-9574-q3cv-v9f8
Updated
2026-11-02
OSV No score

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Record
CVE-2009-0751
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0751 No score

Yaws before 1.80 allows remote attackers to cause a denial of service (memory consumption and crash) via a request with a large number of headers.

Record
DEBIAN-CVE-2009-0751
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
yaws
Debian:12
before 1.80-1
1.80-1
yaws
Debian:13
before 1.80-1
1.80-1
yaws
Debian:14
before 1.80-1
1.80-1
yaws
Debian:4.0
before 1.65-4etch1, plus listed versions
1.65-4
1.65-4etch1
yaws
Debian:5.0
before 1.77-3+lenny1, plus listed versions
1.77-3
1.77-3+lenny1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBYaws < 1.80 - Multiple Headers Remote Denial of Service Vulnerabilities2009-03-03

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0751 is a medium vulnerability (CVSS 5.0) in Yaws, published March 2, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 10.4%, the 95th percentile. Fixed in yaws 1.80-1.

References

Show 5 moreShow less
MoveEnter Open