Every CVE Search/ Get API key

CVE-2002-0838

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and...

4.6 MediumPublic exploitFix available

CVE-2002-0838 is a medium vulnerability (CVSS 4.6) in Ggv, published October 1, 2002. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.02%, the 81st percentile. Fixed in gv 1:3.5.8-27.

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Exploit likelihood

2.02%Down 4.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Record
CVE-2002-0838
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Record
CVE-2002-0838
Updated
2026-11-02
EUVDEUVD-2002-0830 No score

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Record
EUVD-2002-0830
Updated
2026-11-03
GitHub AdvisoriesGHSA-8534-65wr-c3fm No score

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and...

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Record
GHSA-8534-65wr-c3fm
Updated
2026-11-02
OSV No score

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Record
CVE-2002-0838
Updated
2026-11-02
OSVDEBIAN-CVE-2002-0838 No score

Buffer overflow in (1) gv 3.5.8 and earlier, (2) gvv 1.0.2 and earlier, (3) ggv 1.99.90 and earlier, (4) gnome-gv, and (5) kghostview in kdegraphics 2.2.2 and earlier, allows attackers to execute arbitrary code via a malformed (a) PDF or (b) PostScript file, which is processed by an unsafe call to sscanf.

Record
DEBIAN-CVE-2002-0838
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gv
Debian:12
before 1:3.5.8-27
1:3.5.8-27
gv
Debian:13
before 1:3.5.8-27
1:3.5.8-27
gv
Debian:14
before 1:3.5.8-27
1:3.5.8-27
gv
Debian:3.0
before 3.5.8-26.1
3.5.8-26.1
gnome-gv
Debian:3.0
before 1.1.96-3.1
1.1.96-3.1
kdegraphics
Debian:3.0
before 2.2.2-6.8
2.2.2-6.8

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBGV 2.x/3.x - '.PDF'/'.PS' File Buffer Overflow (1)2002-09-26
Exploit-DBGV 2.x/3.x - '.PDF'/'.PS' File Buffer Overflow (2)2002-09-26

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 14 moreShow less
MoveEnter Open