Every CVE Search/ Get API key

CVE-2009-1171

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1...

4.3 MediumPublic exploitFix available

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to read arbitrary files via an input command in a "$$" sequence, which causes LaTeX to include the contents of the file.

Exploit likelihood

6.24%Down 6.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to read arbitrary files via an input command in a "$$" sequence, which causes LaTeX to include the contents of the file.

Record
CVE-2009-1171
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to read arbitrary files via an input command in a "$$" sequence, which causes LaTeX to include the contents of the file.

Record
CVE-2009-1171
Updated
2026-11-02
EUVDEUVD-2009-1171 No score

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to read arbitrary files via an input command in a "$$" sequence, which causes LaTeX to include the contents of the file.

Record
EUVD-2009-1171
Updated
2026-11-03
GitHub AdvisoriesGHSA-c8pm-7v2j-xmww No score

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1...

The TeX filter in Moodle 1.6 before 1.6.9+, 1.7 before 1.7.7+, 1.8 before 1.8.9, and 1.9 before 1.9.5 allows user-assisted attackers to read arbitrary files via an input command in a "$$" sequence, which causes LaTeX to include the contents of the file.

Record
GHSA-c8pm-7v2j-xmww
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle
Debian:4.0
before 1.6.3-2+etch3, plus listed versions
1.6.3-21.6.3-2+etch11.6.3-2+etch2
1.6.3-2+etch3
moodle
Debian:5.0
before 1.8.2.dfsg-3+lenny2, plus listed versions
1.8.2.dfsg-31.8.2.dfsg-3+lenny1
1.8.2.dfsg-3+lenny2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBMoodle < 1.6.9/1.7.7/1.8.9/1.9.5 - File Disclosure2009-03-27

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1171 is a medium vulnerability (CVSS 4.3) in Moodle, published March 30, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 6.24%, the 93rd percentile. Fixed in moodle 1.6.3-2+etch3.

References

Show 10 moreShow less
MoveEnter Open