Every CVE Search/ Get API key

CVE-2009-1271

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote...

5.0 MediumFix available

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote attackers to cause a denial of service (segmentation fault) via a malformed string to the json_decode API function.

Exploit likelihood

2.40%Down 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote attackers to cause a denial of service (segmentation fault) via a malformed string to the json_decode API function.

Record
CVE-2009-1271
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote attackers to cause a denial of service (segmentation fault) via a malformed string to the json_decode API function.

Record
CVE-2009-1271
Updated
2026-11-02
EUVDEUVD-2009-1270 No score

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote attackers to cause a denial of service (segmentation fault) via a malformed string to the json_decode API function.

Record
EUVD-2009-1270
Updated
2026-11-03
GitHub AdvisoriesGHSA-2c9q-p5rf-5vp8 No score

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote...

The JSON_parser function (ext/json/JSON_parser.c) in PHP 5.2.x before 5.2.9 allows remote attackers to cause a denial of service (segmentation fault) via a malformed string to the json_decode API function.

Record
GHSA-2c9q-p5rf-5vp8
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php-json-ext
Debian:4.0
before 1.2.1-3.2+etch1, plus listed versions
1.2.1-3.2
1.2.1-3.2+etch1
php5
Debian:4.0
From an advisory covering 8 CVEs
before 5.2.0+dfsg-8+etch15, plus listed versions
5.2.0-105.2.0-10+lenny15.2.0-115.2.0-8+etch15.2.0-8+etch10
Show 12 moreShow less
5.2.0-8+etch115.2.0-8+etch11~p15.2.0-8+etch135.2.0-8+etch35.2.0-8+etch45.2.0-8+etch5~pu15.2.0-8+etch65.2.0-8+etch75.2.0-8+etch85.2.0-8+etch95.2.0-8+etch9~bpo31+15.2.0-9
5.2.0+dfsg-8+etch15
php5
Debian:5.0
From an advisory covering 8 CVEs
before 5.2.6.dfsg.1-1+lenny3, plus listed versions
5.2.6.dfsg.1-1+lenny2
5.2.6.dfsg.1-1+lenny3
php
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-bcmath
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-cli
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-common
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-dba
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-debuginfo
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-devel
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
Show 13 moreShow less
Affected packages
PackageAffectedFixed
php-gd
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-imap
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-ldap
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-mbstring
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-mysql
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-ncurses
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-odbc
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-pdo
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-pgsql
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-snmp
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-soap
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-xml
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2
php-xmlrpc
Red Hat:rhel_application_stack:2
From an advisory covering 8 CVEs
before 0:5.2.6-4.el5s2
0:5.2.6-4.el5s2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1271 is a medium vulnerability (CVSS 5.0) in Php, published April 8, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.40%, the 84th percentile. Fixed in php-json-ext 1.2.1-3.2+etch1.

References

Show 52 moreShow less
MoveEnter Open