Every CVE Search/ Get API key

CVE-2002-1157

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when...

7.5 HighFix available

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when UseCanonicalName is off and wildcard DNS is enabled, allows remote attackers to execute script as other web site visitors, via the server name in an HTTPS response on the SSL port, which is used in a self-referencing URL, a different vulnerability than CAN-2002-0840.

Exploit likelihood

11.1%Up 7.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when UseCanonicalName is off and wildcard DNS is enabled, allows remote attackers to execute script as other web site visitors, via the server name in an HTTPS response on the SSL port, which is used in a self-referencing URL, a different vulnerability than CAN-2002-0840.

Record
CVE-2002-1157
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when UseCanonicalName is off and wildcard DNS is enabled, allows remote attackers to execute script as other web site visitors, via the server name in an HTTPS response on the SSL port, which is used in a self-referencing URL, a different vulnerability than CAN-2002-0840.

Record
CVE-2002-1157
Updated
2026-11-02
EUVDEUVD-2002-1144 No score

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when UseCanonicalName is off and wildcard DNS is enabled, allows remote attackers to execute script as other web site visitors, via the server name in an HTTPS response on the SSL port, which is used in a self-referencing URL, a different vulnerability than CAN-2002-0840.

Record
EUVD-2002-1144
Updated
2026-11-03
GitHub AdvisoriesGHSA-42vq-2xjj-6g8w No score

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when...

Cross-site scripting vulnerability in the mod_ssl Apache module 2.8.9 and earlier, when UseCanonicalName is off and wildcard DNS is enabled, allows remote attackers to execute script as other web site visitors, via the server name in an HTTPS response on the SSL port, which is used in a self-referencing URL, a different vulnerability than CAN-2002-0840.

Record
GHSA-42vq-2xjj-6g8w
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapache-mod-ssl
Debian:3.0
before 2.8.9-2.1, plus listed versions
2.4.10-1.3.9-1potato22.4.10-1.3.9-1potato42.8.7-1
2.8.9-2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2002-1157 is a high vulnerability (CVSS 7.5) in Mod Ssl Ssl, published October 22, 2002. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.1%, the 95th percentile. Fixed in libapache-mod-ssl 2.8.9-2.1.

References

Show 11 moreShow less
MoveEnter Open