Every CVE Search/ Get API key

CVE-2008-5519

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to...

2.6 LowFix available

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Exploit likelihood

7.26%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Record
CVE-2008-5519
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Record
CVE-2008-5519
Updated
2026-11-02
EUVDEUVD-2008-5494 No score

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Record
EUVD-2008-5494
Updated
2026-11-03
GitHub AdvisoriesGHSA-3v4j-mhgf-pf6w No score

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to...

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Record
GHSA-3v4j-mhgf-pf6w
Weakness
CWE-200
Updated
2026-11-02
OSV No score

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Record
CVE-2008-5519
Updated
2026-11-02
OSVDEBIAN-CVE-2008-5519 No score

The JK Connector (aka mod_jk) 1.2.0 through 1.2.26 in Apache Tomcat allows remote attackers to obtain sensitive information via an arbitrary request from an HTTP client, in opportunistic circumstances involving (1) a request from a different client that included a Content-Length header but no POST data or (2) a rapid series of requests, related to noncompliance with the AJP protocol's requirements for requests containing Content-Length headers.

Record
DEBIAN-CVE-2008-5519
Updated
2026-11-02
OSVopenSUSE-SU-2024:10488-1 No score

apache2-mod_jk-1.2.41-1.5 on GA media

These are all security issues fixed in the apache2-mod_jk-1.2.41-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10488-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapache-mod-jk
Debian:12
before 1:1.2.26-2.1
1:1.2.26-2.1
libapache-mod-jk
Debian:13
before 1:1.2.26-2.1
1:1.2.26-2.1
libapache-mod-jk
Debian:14
before 1:1.2.26-2.1
1:1.2.26-2.1
libapache-mod-jk
Debian:4.0
before 1:1.2.18-3etch2, plus listed versions
1:1.2.18-31:1.2.18-3etch1
1:1.2.18-3etch2
libapache-mod-jk
Debian:5.0
before 1:1.2.26-2+lenny1, plus listed versions
1:1.2.26-2
1:1.2.26-2+lenny1
mod_jk
Red Hat:rhel_application_stack:2
before 0:1.2.28-1.el5s2
0:1.2.28-1.el5s2
mod_jk-ap20
Red Hat:rhel_application_stack:2
before 0:1.2.28-1.el5s2
0:1.2.28-1.el5s2
mod_jk-debuginfo
Red Hat:rhel_application_stack:2
before 0:1.2.28-1.el5s2
0:1.2.28-1.el5s2
mod_jk
Red Hat:rhel_application_server:2
before 0:1.2.28-1jpp_3rh
0:1.2.28-1jpp_3rh
mod_jk-ap20
Red Hat:rhel_application_server:2
before 0:1.2.28-1jpp_3rh
0:1.2.28-1jpp_3rh
Show 9 moreShow less
Affected packages
PackageAffectedFixed
mod_jk-debuginfo
Red Hat:rhel_application_server:2
before 0:1.2.28-1jpp_3rh
0:1.2.28-1jpp_3rh
mod_jk-manual
Red Hat:rhel_application_server:2
before 0:1.2.28-1jpp_3rh
0:1.2.28-1jpp_3rh
mod_jk
Red Hat:network_satellite:5.1::el4
before 0:1.2.25-10
0:1.2.25-10
mod_jk-ap20
Red Hat:network_satellite:5.1::el4
before 0:1.2.25-10
0:1.2.25-10
mod_jk-debuginfo
Red Hat:network_satellite:5.1::el4
before 0:1.2.25-10
0:1.2.25-10
mod_jk
Red Hat:network_satellite:5.2::el4
before 0:1.2.25-10
0:1.2.25-10
mod_jk-ap20
Red Hat:network_satellite:5.2::el4
before 0:1.2.25-10
0:1.2.25-10
mod_jk-debuginfo
Red Hat:network_satellite:5.2::el4
before 0:1.2.25-10
0:1.2.25-10
apache2-mod_jk
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 1.2.41-1.5
1.2.41-1.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2008-5519 is a low vulnerability (CVSS 2.6) in Apache Tomcat, published April 9, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.26%, the 94th percentile. Fixed in libapache-mod-jk 1:1.2.26-2.1.

References

Show 41 moreShow less
MoveEnter Open