Every CVE Search/ Get API key

CVE-2009-1195

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options...

4.9 MediumFix available

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Exploit likelihood

1.96%Down 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.9

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Record
CVE-2009-1195
CVSS 2.0
4.9 MediumAV:L/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-16
Updated
2026-11-02
CVE List No score

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Record
CVE-2009-1195
Updated
2026-11-02
EUVDEUVD-2009-1194 No score

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Record
EUVD-2009-1194
Updated
2026-11-03
GitHub AdvisoriesGHSA-pxp4-3gwj-j6m3 No score

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options...

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Record
GHSA-pxp4-3gwj-j6m3
Updated
2026-11-02
OSV No score

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Record
CVE-2009-1195
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1195 No score

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive, which allows local users to gain privileges by configuring (1) Options Includes, (2) Options +Includes, or (3) Options +IncludesNOEXEC in a .htaccess file, and then inserting an exec element in a .shtml file.

Record
DEBIAN-CVE-2009-1195
Updated
2026-11-02
OSVopenSUSE-SU-2024:10268-1 No score

apache2-2.4.23-4.1 on GA media

These are all security issues fixed in the apache2-2.4.23-4.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10268-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache2
Debian:12
before 2.2.11-6
2.2.11-6
apache2
Debian:13
before 2.2.11-6
2.2.11-6
apache2
Debian:14
before 2.2.11-6
2.2.11-6
apache2
Debian:4.0
before 2.2.3-4+etch8, plus listed versions
2.2.3-42.2.3-4+etch12.2.3-4+etch22.2.3-4+etch32.2.3-4+etch42.2.3-4+etch52.2.3-4+etch6
2.2.3-4+etch8
apache2
Debian:5.0
before 2.2.9-10+lenny3, plus listed versions
2.2.9-10+lenny2
2.2.9-10+lenny3
httpd
Red Hat:enterprise_linux:5::client_workstation
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd-manual
Red Hat:enterprise_linux:5::client_workstation
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd
Red Hat:enterprise_linux:5::client
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
Show 25 moreShow less
Affected packages
PackageAffectedFixed
httpd-debuginfo
Red Hat:enterprise_linux:5::client
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
mod_ssl
Red Hat:enterprise_linux:5::client
before 1:2.2.3-22.el5_3.1
1:2.2.3-22.el5_3.1
httpd
Red Hat:enterprise_linux:5::server
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd-debuginfo
Red Hat:enterprise_linux:5::server
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd-devel
Red Hat:enterprise_linux:5::server
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
httpd-manual
Red Hat:enterprise_linux:5::server
before 0:2.2.3-22.el5_3.1
0:2.2.3-22.el5_3.1
mod_ssl
Red Hat:enterprise_linux:5::server
before 1:2.2.3-22.el5_3.1
1:2.2.3-22.el5_3.1
httpd
Red Hat:jboss_enterprise_web_server:1::el5
before 0:2.2.10-10.ep5.el5
0:2.2.10-10.ep5.el5
httpd-devel
Red Hat:jboss_enterprise_web_server:1::el5
before 0:2.2.10-10.ep5.el5
0:2.2.10-10.ep5.el5
httpd-manual
Red Hat:jboss_enterprise_web_server:1::el5
before 0:2.2.10-10.ep5.el5
0:2.2.10-10.ep5.el5
mod_ssl
Red Hat:jboss_enterprise_web_server:1::el5
before 1:2.2.10-10.ep5.el5
1:2.2.10-10.ep5.el5
httpd
Red Hat:rhel_application_stack:2
before 0:2.2.11-3.el5s2
0:2.2.11-3.el5s2
httpd-debuginfo
Red Hat:rhel_application_stack:2
before 0:2.2.11-3.el5s2
0:2.2.11-3.el5s2
httpd-devel
Red Hat:rhel_application_stack:2
before 0:2.2.11-3.el5s2
0:2.2.11-3.el5s2
httpd-manual
Red Hat:rhel_application_stack:2
before 0:2.2.11-3.el5s2
0:2.2.11-3.el5s2
mod_ssl
Red Hat:rhel_application_stack:2
before 1:2.2.11-3.el5s2
1:2.2.11-3.el5s2
httpd22
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
httpd22-apr
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
httpd22-apr-devel
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
httpd22-apr-util
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
httpd22-apr-util-devel
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
httpd22-debuginfo
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
httpd22-devel
Red Hat:jboss_enterprise_web_server:1::el4
before 0:2.2.10-23.1.ep5.el4
0:2.2.10-23.1.ep5.el4
mod_ssl22
Red Hat:jboss_enterprise_web_server:1::el4
before 1:2.2.10-23.1.ep5.el4
1:2.2.10-23.1.ep5.el4
apache2
openSUSE:Tumbleweed
before 2.4.23-4.1
2.4.23-4.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1195 is a medium vulnerability (CVSS 4.9) in Apache Http Server, published May 28, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in apache2 2.2.11-6.

References

Show 134 moreShow less
MoveEnter Open