Every CVE Search/ Get API key

CVE-2009-1438

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8...

7.5 HighFix available

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Exploit likelihood

4.67%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Record
CVE-2009-1438
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Record
CVE-2009-1438
Updated
2026-11-02
EUVDEUVD-2009-1436 No score

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Record
EUVD-2009-1436
Updated
2026-11-03
GitHub AdvisoriesGHSA-v7cc-2p5c-5943 No score

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8...

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Record
GHSA-v7cc-2p5c-5943
Updated
2026-11-02
OSV No score

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Record
CVE-2009-1438
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1438 No score

Integer overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.

Record
DEBIAN-CVE-2009-1438
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libmodplug
Debian:12
before 1:0.8.7-1
1:0.8.7-1
libmodplug
Debian:13
before 1:0.8.7-1
1:0.8.7-1
libmodplug
Debian:14
before 1:0.8.7-1
1:0.8.7-1
libmodplug
Debian:4.0
From an advisory covering 2 CVEs
before 1:0.7-5.2+etch1, plus listed versions
1:0.7-5.2
1:0.7-5.2+etch1
libmodplug
Debian:5.0
From an advisory covering 2 CVEs
before 1:0.8.4-1+lenny1, plus listed versions
1:0.8.4-1
1:0.8.4-1+lenny1
gst-plugins-bad0.10
Debian:4.0
before 0.10.3-3.1+etch3, plus listed versions
0.10.3-3.10.10.3-3.1+etch1
0.10.3-3.1+etch3
gst-plugins-bad0.10
Debian:5.0
before 0.10.7-2+lenny2, plus listed versions
0.10.7-2
0.10.7-2+lenny2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1438 is a high vulnerability (CVSS 7.5) in Konstanty Bialkowski Libmodplug, published April 27, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.67%, the 91st percentile. Fixed in libmodplug 1:0.8.7-1.

References

Show 22 moreShow less
MoveEnter Open