Every CVE Search/ Get API key

CVE-2009-3474

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth...

7.5 HighFix available

CVE-2009-3474 is a high vulnerability (CVSS 7.5) in Internet2 Opensaml, published September 24, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 75th percentile. Fixed in opensaml 3.0.0-2.

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Exploit likelihood

1.54%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Record
CVE-2009-3474
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-310
Updated
2026-11-02
CVE List No score

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Record
CVE-2009-3474
Updated
2026-11-02
EUVDEUVD-2009-3456 No score

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Record
EUVD-2009-3456
Updated
2026-11-03
GitHub AdvisoriesGHSA-575w-rwc7-4259 No score

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth...

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Record
GHSA-575w-rwc7-4259
Updated
2026-11-02
OSV No score

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Record
CVE-2009-3474
Updated
2026-11-02
OSVDEBIAN-CVE-2009-3474 No score

OpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.

Record
DEBIAN-CVE-2009-3474
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opensaml
Debian:12
before 3.0.0-2
3.0.0-2
opensaml
Debian:13
before 3.0.0-2
3.0.0-2
opensaml
Debian:14
before 3.0.0-2
3.0.0-2
shibboleth-sp
Debian:12
before 3.0.2+dfsg1-2
3.0.2+dfsg1-2
shibboleth-sp
Debian:13
before 3.0.2+dfsg1-2
3.0.2+dfsg1-2
shibboleth-sp
Debian:14
before 3.0.2+dfsg1-2
3.0.2+dfsg1-2
xmltooling
Debian:12
before 1.2.2-1
1.2.2-1
xmltooling
Debian:13
before 1.2.2-1
1.2.2-1
xmltooling
Debian:14
before 1.2.2-1
1.2.2-1
xmltooling
Debian:5.0
before 1.0-2+lenny1, plus listed versions
1.0-2
1.0-2+lenny1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
opensaml2
Debian:5.0
before 2.0-2+lenny1, plus listed versions
2.0-2
2.0-2+lenny1
shibboleth-sp2
Debian:5.0
before 2.0.dfsg1-4+lenny1, plus listed versions
2.0.dfsg1-4
2.0.dfsg1-4+lenny1
opensaml
Debian:4.0
before 1.1a-2+etch1, plus listed versions
1.1a-2
1.1a-2+etch1
shibboleth-sp
Debian:4.0
before 1.3f.dfsg1-2+etch1, plus listed versions
1.3f.dfsg1-2
1.3f.dfsg1-2+etch1
opensaml
Debian:5.0
before 1.1.1-2+lenny1, plus listed versions
1.1.1-21.1.1-2+lenny1~bpo40+1
1.1.1-2+lenny1
shibboleth-sp
Debian:5.0
before 1.3.1.dfsg1-3+lenny1, plus listed versions
1.3.1.dfsg1-31.3.1.dfsg1-3+lenny1~bpo40+1
1.3.1.dfsg1-3+lenny1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open