Every CVE Search/ Get API key

CVE-2011-1754

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which...

5.0 MediumFix available

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Exploit likelihood

2.27%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-1754
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-1754
Updated
2026-11-02
EUVDEUVD-2011-1753 No score

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
EUVD-2011-1753
Updated
2026-11-03
GitHub AdvisoriesGHSA-p7w4-2fhg-mqv6 No score

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which...

jabberd14 1.6.1.1 and earlier does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
GHSA-p7w4-2fhg-mqv6
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jabberd14
Debian:6.0
before 1.6.1.1-5+squeeze1, plus listed versions
1.6.1.1-5
1.6.1.1-5+squeeze1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1754 is a medium vulnerability (CVSS 5.0) in Jabberd Jabberd14, published May 31, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. Fixed in jabberd14 1.6.1.1-5+squeeze1.

References

MoveEnter Open