Every CVE Search/ Get API key

CVE-2011-2696

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service...

6.8 MediumFix available

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Exploit likelihood

4.65%Down 2.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Record
CVE-2011-2696
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Record
CVE-2011-2696
Updated
2026-11-02
EUVDEUVD-2011-2677 No score

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Record
EUVD-2011-2677
Updated
2026-11-03
GitHub AdvisoriesGHSA-pq4x-r6mp-pmm3 No score

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service...

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Record
GHSA-pq4x-r6mp-pmm3
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Record
CVE-2011-2696
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2696 No score

Integer overflow in libsndfile before 1.0.25 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PARIS Audio Format (PAF) file that triggers a heap-based buffer overflow.

Record
DEBIAN-CVE-2011-2696
Updated
2026-11-02
OSVopenSUSE-SU-2024:10148-1 No score

libsndfile-devel-1.0.26-2.4 on GA media

These are all security issues fixed in the libsndfile-devel-1.0.26-2.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10148-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10470-1 No score

libsndfile-progs-1.0.26-2.4 on GA media

These are all security issues fixed in the libsndfile-progs-1.0.26-2.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10470-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsndfile
Debian:12
before 1.0.25-1
1.0.25-1
libsndfile
Debian:13
before 1.0.25-1
1.0.25-1
libsndfile
Debian:14
before 1.0.25-1
1.0.25-1
libsndfile
Debian:6.0
before 1.0.21-3+squeeze1, plus listed versions
1.0.21-31.0.21-3+squeeze1~bpo50+1
1.0.21-3+squeeze1
libsndfile
Debian:5.0
before 1.0.17-4+lenny3, plus listed versions
1.0.17-41.0.17-4+lenny11.0.17-4+lenny2
1.0.17-4+lenny3
libsndfile
Red Hat:enterprise_linux:6::server
before 0:1.0.20-3.el6_1.1
0:1.0.20-3.el6_1.1
libsndfile-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.0.20-3.el6_1.1
0:1.0.20-3.el6_1.1
libsndfile-devel
Red Hat:enterprise_linux:6::server
before 0:1.0.20-3.el6_1.1
0:1.0.20-3.el6_1.1
libsndfile
openSUSE:Tumbleweed
before 1.0.26-2.4
1.0.26-2.4
libsndfile-progs
openSUSE:Tumbleweed
before 1.0.26-2.4
1.0.26-2.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2696 is a medium vulnerability (CVSS 6.8) in Mega-nerd Libsndfile, published July 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.65%, the 91st percentile. Fixed in libsndfile 1.0.25-1.

References

Show 32 moreShow less
MoveEnter Open