Every CVE Search/ Get API key

CVE-2011-1528

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka...

7.8 HighFix available

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Exploit likelihood

4.18%Up 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Record
CVE-2011-1528
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Record
CVE-2011-1528
Updated
2026-11-02
EUVDEUVD-2011-1529 No score

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Record
EUVD-2011-1529
Updated
2026-11-03
GitHub AdvisoriesGHSA-hxvv-vjx9-wj2m No score

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka...

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Record
GHSA-hxvv-vjx9-wj2m
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Record
CVE-2011-1528
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1528 No score

The krb5_ldap_lockout_audit function in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.8 through 1.8.4 and 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via unspecified vectors, related to the locked_check_p function. NOTE: the Berkeley DB vector is covered by CVE-2011-4151.

Record
DEBIAN-CVE-2011-1528
Updated
2026-11-02
OSVopenSUSE-SU-2024:10004-1 No score

krb5-1.15-1.1 on GA media

These are all security issues fixed in the krb5-1.15-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10004-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
krb5
Debian:12
before 1.10+dfsg~alpha1-1
1.10+dfsg~alpha1-1
krb5
Debian:13
before 1.10+dfsg~alpha1-1
1.10+dfsg~alpha1-1
krb5
Debian:14
before 1.10+dfsg~alpha1-1
1.10+dfsg~alpha1-1
krb5
Debian:6.0
before 1.8.3+dfsg-4squeeze5, plus listed versions
1.8.3+dfsg-41.8.3+dfsg-4squeeze11.8.3+dfsg-4squeeze2
1.8.3+dfsg-4squeeze5
krb5
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-debuginfo
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-devel
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-libs
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-pkinit-openssl
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-server
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-server-ldap
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5-workstation
Red Hat:enterprise_linux:6::server
before 0:1.9-9.el6_1.2
0:1.9-9.el6_1.2
krb5
openSUSE:Tumbleweed
before 1.15-1.1
1.15-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1528 is a high vulnerability (CVSS 7.8) in Mit Kerberos 5, published October 20, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.18%, the 90th percentile. Fixed in krb5 1.10+dfsg~alpha1-1.

References

Show 70 moreShow less
MoveEnter Open