CVE-2011-2082
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4...
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
Exploit likelihood
What each source reports
NVD Score used
5.0
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
- Record
CVE-2011-2082- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-255
- Updated
- 2026-11-02
CVE List No score
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
- Record
CVE-2011-2082- Updated
- 2026-11-02
EUVDEUVD-2011-2076 No score
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
- Record
EUVD-2011-2076- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pxc3-v4rj-fc78 No score
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4...
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
- Record
GHSA-pxc3-v4rj-fc78- Updated
- 2026-11-02
OSV No score
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
- Record
CVE-2011-2082- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-2082 No score
The vulnerable-passwords script in Best Practical Solutions RT 3.x before 3.8.12 and 4.x before 4.0.6 does not update the password-hash algorithm for disabled user accounts, which makes it easier for context-dependent attackers to determine cleartext passwords, and possibly use these passwords after accounts are re-enabled, via a brute-force attack on the database. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-0009.
- Record
DEBIAN-CVE-2011-2082- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
request-tracker4Debian:12 |
before 4.0.5-3 | 4.0.5-3 |
request-tracker3.8Debian:6.0 From an advisory covering 7 CVEs |
before 3.8.8-7+squeeze2, plus listed versions 3.8.8-73.8.8-7+squeeze13.8.8-7+squeeze1~bpo50+1 |
3.8.8-7+squeeze2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-2082 is a medium vulnerability (CVSS 5.0) in Bestpractical Rt, published May 24, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.18%, the 67th percentile. Fixed in request-tracker4 4.0.5-3.
References
lists.bestpractical.com/pipermail/rt-announce/2012-May/000203.html
secunia.com/advisories/49259
lists.bestpractical.com/pipermail/rt-announce/2012-May/000204.html
lists.bestpractical.com/pipermail/rt-announce/2012-May/000202.html
securityfocus.com/bid/53660
nvd.nist.gov/vuln/detail/CVE-2011-2082
github.com/advisories/GHSA-pxc3-v4rj-fc78
security-tracker.debian.org/tracker/CVE-2011-2082