Every CVE Search/ Get API key

CVE-2012-1177

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows...

5.1 MediumFix available

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Exploit likelihood

1.90%Down 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Record
CVE-2012-1177
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Record
CVE-2012-1177
Updated
2026-11-02
EUVDEUVD-2012-1206 No score

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Record
EUVD-2012-1206
Updated
2026-11-03
GitHub AdvisoriesGHSA-fhp4-5rwr-h9r6 No score

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows...

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Record
GHSA-fhp4-5rwr-h9r6
Weakness
CWE-20
Updated
2026-11-02
OSV No score

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Record
CVE-2012-1177
Updated
2026-11-02
OSVDEBIAN-CVE-2012-1177 No score

libgdata before 0.10.2 and 0.11.x before 0.11.1 does not validate SSL certificates, which allows remote attackers to obtain user names and passwords via a man-in-the-middle (MITM) attack with a spoofed certificate.

Record
DEBIAN-CVE-2012-1177
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgdata
Debian:12
before 0.10.2-1
0.10.2-1
libgdata
Debian:13
before 0.10.2-1
0.10.2-1
libgdata
Debian:6.0
before 0.6.4-2+squeeze1, plus listed versions
0.6.4-2
0.6.4-2+squeeze1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-1177 is a medium vulnerability (CVSS 5.1) in Gnome Libgdata, published May 28, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in libgdata 0.10.2-1.

References

Show 9 moreShow less
MoveEnter Open