Every CVE Search/ Get API key

CVE-2012-3291

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service...

7.8 HighFix available

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Exploit likelihood

2.30%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Record
CVE-2012-3291
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Record
CVE-2012-3291
Updated
2026-11-02
EUVDEUVD-2012-3269 No score

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Record
EUVD-2012-3269
Updated
2026-11-03
GitHub AdvisoriesGHSA-6578-wffp-8556 No score

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service...

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Record
GHSA-6578-wffp-8556
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Record
CVE-2012-3291
Updated
2026-11-02
OSVDEBIAN-CVE-2012-3291 No score

Heap-based buffer overflow in OpenConnect 3.18 allows remote servers to cause a denial of service via a crafted greeting banner.

Record
DEBIAN-CVE-2012-3291
Updated
2026-11-02
OSVopenSUSE-SU-2024:10553-1 No score

openconnect-7.07-1.3 on GA media

These are all security issues fixed in the openconnect-7.07-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10553-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openconnect
Debian:12
before 3.18-1
3.18-1
openconnect
Debian:13
before 3.18-1
3.18-1
openconnect
Debian:14
before 3.18-1
3.18-1
openconnect
Debian:6.0
before 2.25-0.1+squeeze1, plus listed versions
2.25-0.1
2.25-0.1+squeeze1
openconnect
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 7.07-1.3
7.07-1.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-3291 is a high vulnerability (CVSS 7.8) in Infradead Openconnect, published June 7, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.30%, the 83rd percentile. Fixed in openconnect 3.18-1.

References

Show 6 moreShow less
MoveEnter Open