Every CVE Search/ Get API key

CVE-2012-4523

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration...

6.4 MediumFix available

CVE-2012-4523 is a medium vulnerability (CVSS 6.4) in Uninett Radsecproxy, published November 10, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in radsecproxy 1.6.2-1.

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Exploit likelihood

1.76%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Record
CVE-2012-4523
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Record
CVE-2012-4523
Updated
2026-11-02
EUVDEUVD-2012-4451 No score

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Record
EUVD-2012-4451
Updated
2026-11-03
GitHub AdvisoriesGHSA-67pw-2qx3-43v6 No score

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration...

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Record
GHSA-67pw-2qx3-43v6
Updated
2026-11-02
OSV No score

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Record
CVE-2012-4523
Updated
2026-11-02
OSVDEBIAN-CVE-2012-4523 No score

radsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.

Record
DEBIAN-CVE-2012-4523
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
radsecproxy
Debian:12
before 1.6.2-1
1.6.2-1
radsecproxy
Debian:13
before 1.6.2-1
1.6.2-1
radsecproxy
Debian:14
before 1.6.2-1
1.6.2-1
radsecproxy
Debian:6.0
before 1.4-1+squeeze1, plus listed versions
1.4-1
1.4-1+squeeze1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open