Every CVE Search/ Get API key

CVE-2013-0333

activesupport in Rails vulnerable to incorrect data conversion

7.5 HighPublic exploitFix available

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Exploit likelihood

95.6%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
CVE-2013-0333
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
CVE-2013-0333
Updated
2026-11-02
EUVDEUVD-2017-0331 No score

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
EUVD-2017-0331
Updated
2026-11-03
GitHub AdvisoriesGHSA-xgr2-v94m-rc9g No score

activesupport in Rails vulnerable to incorrect data conversion

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
GHSA-xgr2-v94m-rc9g
Weakness
CWE-74
Updated
2026-11-02
OSV No score

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
CVE-2013-0333
Updated
2026-11-02
OSVDEBIAN-CVE-2013-0333 No score

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
DEBIAN-CVE-2013-0333
Updated
2026-11-02
OSVGHSA-xgr2-v94m-rc9g No score

activesupport in Rails vulnerable to incorrect data conversion

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Record
GHSA-xgr2-v94m-rc9g
Weakness
CWE-74
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
activesupport
RubyGems
2.3.2 up to 2.3.16
2.3.16
activesupport
RubyGems
3.0.0 up to 3.0.20
3.0.20
rails
Debian:12
before 2.3.14.1
2.3.14.1
rails
Debian:13
before 2.3.14.1
2.3.14.1
rails
Debian:14
before 2.3.14.1
2.3.14.1
rails
Debian:6.0
before 2.3.5-1.2+squeeze6, plus listed versions
2.3.5-1.22.3.5-1.2+squeeze0.12.3.5-1.2+squeeze12.3.5-1.2+squeeze22.3.5-1.2+squeeze32.3.5-1.2+squeeze42.3.5-1.2+squeeze4.12.3.5-1.2+squeeze5
2.3.5-1.2+squeeze6
activesupport
RubyGems
2.3.2 up to 2.3.16, plus listed versions
2.3.102.3.112.3.122.3.142.3.15
Show 10 moreShow less
2.3.32.3.42.3.52.3.62.3.6.pre2.3.72.3.82.3.8.pre12.3.92.3.9.pre
2.3.16
activesupport
RubyGems
3.0.0 up to 3.0.20, plus listed versions
3.0.13.0.103.0.10.rc13.0.113.0.12
Show 30 moreShow less
3.0.12.rc13.0.133.0.13.rc13.0.143.0.153.0.163.0.173.0.183.0.193.0.23.0.33.0.43.0.4.rc13.0.53.0.5.rc13.0.63.0.6.rc13.0.6.rc23.0.73.0.7.rc13.0.7.rc23.0.83.0.8.rc13.0.8.rc23.0.8.rc43.0.93.0.9.rc13.0.9.rc33.0.9.rc43.0.9.rc5
3.0.20
rubygem-activesupport
Red Hat:openshift:1::el6
before 1:3.0.13-4.el6op
1:3.0.13-4.el6op

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-0333 is a high vulnerability (CVSS 7.5) in Rubyonrails Rails, published January 29, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 95.6%, the 99th percentile. Fixed in activesupport 2.3.16.

References

Show 18 moreShow less
MoveEnter Open