CVE-2003-0146
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow...
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
Exploit likelihood
What each source reports
NVD Score used
7.5
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
- Record
CVE-2003-0146- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
- Record
CVE-2003-0146- Updated
- 2026-11-02
EUVDEUVD-2003-0142 No score
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
- Record
EUVD-2003-0142- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w8mv-4w2v-qfg8 No score
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow...
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
- Record
GHSA-w8mv-4w2v-qfg8- Updated
- 2026-11-02
OSV No score
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
- Record
CVE-2003-0146- Updated
- 2026-11-02
OSVDEBIAN-CVE-2003-0146 No score
Multiple vulnerabilities in NetPBM 9.20 and earlier, and possibly other versions, may allow remote attackers to cause a denial of service or execute arbitrary code via "maths overflow errors" such as (1) integer signedness errors or (2) integer overflows, which lead to buffer overflows.
- Record
DEBIAN-CVE-2003-0146- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lprDebian:12 |
before 1:2000.05.07-4.20 | 1:2000.05.07-4.20 |
lprDebian:13 |
before 1:2000.05.07-4.20 | 1:2000.05.07-4.20 |
lprDebian:14 |
before 1:2000.05.07-4.20 | 1:2000.05.07-4.20 |
netpbm-freeDebian:12 |
before 2:9.20-9 | 2:9.20-9 |
netpbm-freeDebian:13 |
before 2:9.20-9 | 2:9.20-9 |
netpbm-freeDebian:14 |
before 2:9.20-9 | 2:9.20-9 |
netpbm-freeDebian:3.0 |
before 2:9.20-8.2 | 2:9.20-8.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2003-0146 is a high vulnerability (CVSS 7.5) in Netpbm, published March 17, 2003. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.54%, the 93rd percentile. Fixed in lpr 1:2000.05.07-4.20.