Every CVE Search/ Get API key

CVE-2013-1640

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18,...

9.0 HighFix available

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Exploit likelihood

4.93%Down 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.0

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Record
CVE-2013-1640
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Record
CVE-2013-1640
Updated
2026-11-02
EUVDEUVD-2013-1671 No score

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Record
EUVD-2013-1671
Updated
2026-11-03
GitHub AdvisoriesGHSA-86qh-qpc6-jff7 No score

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18,...

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Record
GHSA-86qh-qpc6-jff7
Updated
2026-11-02
OSV No score

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Record
CVE-2013-1640
Updated
2026-11-02
OSVDEBIAN-CVE-2013-1640 No score

The (1) template and (2) inline_template functions in the master server in Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2 allows remote authenticated users to execute arbitrary code via a crafted catalog request.

Record
DEBIAN-CVE-2013-1640
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
Debian:11
before 2.7.18-3
2.7.18-3
puppet
Debian:6.0
From an advisory covering 7 CVEs
before 2.6.2-5+squeeze7, plus listed versions
2.6.2-42.6.2-52.6.2-5+squeeze12.6.2-5+squeeze32.6.2-5+squeeze42.6.2-5+squeeze52.6.2-5+squeeze6
2.6.2-5+squeeze7
puppet
Red Hat:openstack:2::el6
From an advisory covering 6 CVEs
before 0:2.6.18-1.el6ost
0:2.6.18-1.el6ost
puppet-server
Red Hat:openstack:2::el6
From an advisory covering 6 CVEs
before 0:2.6.18-1.el6ost
0:2.6.18-1.el6ost

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1640 is a high vulnerability (CVSS 9.0) in Puppet, published March 12, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.93%, the 92nd percentile. Fixed in puppet 2.7.18-3.

References

Show 31 moreShow less
MoveEnter Open