Every CVE Search/ Get API key

CVE-2013-2236

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api...

2.6 LowFix available

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

Exploit likelihood

2.08%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.6

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

Record
CVE-2013-2236
CVSS 2.0
2.6 LowAV:N/AC:H/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

Record
CVE-2013-2236
Updated
2026-11-02
EUVDEUVD-2013-2187 No score

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

Record
EUVD-2013-2187
Updated
2026-11-03
GitHub AdvisoriesGHSA-4pv9-4pjh-rpv5 No score

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api...

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

Record
GHSA-4pv9-4pjh-rpv5
Weakness
CWE-119
Updated
2026-11-02
OSVRHSA-2017:0794 6.5

Red Hat Security Advisory: quagga security and bug fix update

Record
RHSA-2017:0794
CVSS 3.0
6.5 MediumCVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2013-0310 No score

Updated quagga packages fix CVE-2013-2236

Updated quagga packages fix security vulnerability:

Remotely exploitable buffer overflow in ospf_api.c and ospfclient.c when processing LSA messages in quagga before 0.99.22.2 (CVE-2013-2236).

Note: We have worked around this vulnerability by disabling the ospf_api and ospfclient features, which did not provide useful functionality.

Record
MGASA-2013-0310
Updated
2026-11-02
OSVopenSUSE-SU-2024:10362-1 No score

libospf0-1.0.20160315-5.1 on GA media

These are all security issues fixed in the libospf0-1.0.20160315-5.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10362-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-2236 No score

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

Record
UBUNTU-CVE-2013-2236
Updated
2026-11-02
OSVUSN-2941-1 No score

quagga vulnerabilities

Kostya Kortchinsky discovered that Quagga incorrectly handled certain route data when configured with BGP peers enabled for VPNv4. A remote attacker could use this issue to cause Quagga to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2016-2342)

It was discovered that Quagga incorrectly handled messages with a large LSA when used in certain configurations. A remote attacker could use this issue to cause Quagga to crash, resulting in a denial of service. This issue only affected Ubuntu 12.04 LTS. (CVE-2013-2236)

Record
USN-2941-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
quagga
Debian:6.0
before 0.99.20.1-0+squeeze5, plus listed versions
0.99.17-20.99.17-2+squeeze20.99.17-2+squeeze30.99.17-30.99.17-4
Show 12 moreShow less
0.99.18-10.99.18-20.99.19-10.99.20-10.99.20-1~bpo60+10.99.20-20.99.20-30.99.20-40.99.20.1-0+squeeze10.99.20.1-0+squeeze20.99.20.1-0+squeeze30.99.20.1-0+squeeze4
0.99.20.1-0+squeeze5
quagga
Debian:7
before 0.99.22.4-1+wheezy1, plus listed versions
0.99.21-4+wheezy10.99.21-4+wheezy20.99.22-10.99.22.1-10.99.22.1-20.99.22.4-1
0.99.22.4-1+wheezy1
quagga
Mageia:2
before 0.99.20.1-3.2.mga2
0.99.20.1-3.2.mga2
quagga
Mageia:3
before 0.99.20.1-9.1.mga3
0.99.20.1-9.1.mga3
quagga-contrib
Red Hat:enterprise_linux:6::server
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga-debuginfo
Red Hat:enterprise_linux:6::server
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga-devel
Red Hat:enterprise_linux:6::server
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga
Red Hat:enterprise_linux:6::server
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga-contrib
Red Hat:enterprise_linux:6::workstation
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:0.99.15-14.el6
0:0.99.15-14.el6
Show 4 moreShow less
Affected packages
PackageAffectedFixed
quagga-devel
Red Hat:enterprise_linux:6::workstation
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga
Red Hat:enterprise_linux:6::workstation
before 0:0.99.15-14.el6
0:0.99.15-14.el6
quagga
Ubuntu:14.04:LTS
before 0.99.22.4-3ubuntu1.1, plus listed versions
0.99.22.1-20.99.22.4-10.99.22.4-20.99.22.4-30.99.22.4-3ubuntu1
0.99.22.4-3ubuntu1.1
quagga
openSUSE:Tumbleweed
before 1.0.20160315-5.1
1.0.20160315-5.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2236 is a low vulnerability (CVSS 2.6) in Quagga, published October 17, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.08%, the 81st percentile. Fixed in quagga 0.99.20.1-0+squeeze5.

References

Show 48 moreShow less
MoveEnter Open