Every CVE Search/ Get API key

CVE-2014-0185

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x...

7.2 HighFix available

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.

Exploit likelihood

0.48%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.

Record
CVE-2014-0185
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-269
Updated
2026-11-02
CVE List No score

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.

Record
CVE-2014-0185
Updated
2026-11-02
EUVDEUVD-2014-0237 No score

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.

Record
EUVD-2014-0237
Updated
2026-11-03
GitHub AdvisoriesGHSA-g7xr-pqqf-vpjw No score

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x...

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.

Record
GHSA-g7xr-pqqf-vpjw
Weakness
CWE-269
Updated
2026-11-02
OSVMGASA-2014-0215 No score

Updated php packages fix CVE-2014-0185

Updated php packages fix security vulnerability:

PHP FPM in PHP versions before 5.4.28 and 5.5.12 uses a UNIX domain socket with world-writable permissions by default, which allows any local user to connect to it and execute PHP scripts as the apache user (CVE-2014-0185).

Additionally updated php-suhosin package corrects an issue which could cause a segfault in apache. Also updated is php-timezonedb.

Record
MGASA-2014-0215
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
Show 5 moreShow less
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10487-1 No score

froxlor-0.9.38.4-1.1 on GA media

These are all security issues fixed in the froxlor-0.9.38.4-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10487-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11169-1 No score

php8-8.0.11-1.1 on GA media

These are all security issues fixed in the php8-8.0.11-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11169-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-0185 No score

sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.

Record
UBUNTU-CVE-2014-0185
Updated
2026-11-02
OSVUSN-2254-1 No score

php5 vulnerabilities

Christian Hoffmann discovered that the PHP FastCGI Process Manager (FPM) set incorrect permissions on the UNIX socket. A local attacker could use this issue to possibly elevate their privileges. This issue only affected Ubuntu 12.04 LTS, Ubuntu 13.10, and Ubuntu 14.04 LTS. (CVE-2014-0185)

Francisco Alonso discovered that the PHP Fileinfo component incorrectly handled certain CDF documents. A remote attacker could use this issue to cause PHP to hang or crash, resulting in a denial of service. (CVE-2014-0237, CVE-2014-0238)

Stefan Esser discovered that PHP incorrectly handled DNS TXT records. A remote attacker could use this issue to cause PHP to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2014-4049)

Record
USN-2254-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php5
Debian:7
before 5.4.4-14+deb7u10, plus listed versions
5.4.4-145.4.4-14+deb7u15.4.4-14+deb7u25.4.4-14+deb7u35.4.4-14+deb7u4
Show 4 moreShow less
5.4.4-14+deb7u55.4.4-14+deb7u75.4.4-14+deb7u85.4.4-14+deb7u9
5.4.4-14+deb7u10
php
Mageia:3
before 5.4.28-1.mga3
5.4.28-1.mga3
php-gd-bundled
Mageia:3
before 5.4.28-1.mga3
5.4.28-1.mga3
php-apc
Mageia:3
before 3.1.14-7.8.mga3
3.1.14-7.8.mga3
php-suhosin
Mageia:3
before 0.9.35-1.mga3
0.9.35-1.mga3
php-timezonedb
Mageia:3
before 2014.3-1.mga3
2014.3-1.mga3
php
Mageia:4
before 5.5.12-1.mga4
5.5.12-1.mga4
php-apc
Mageia:4
before 3.1.15-4.3.mga4
3.1.15-4.3.mga4
php-suhosin
Mageia:4
before 0.9.35-1.mga4
0.9.35-1.mga4
php-timezonedb
Mageia:4
before 2014.3-1.mga4
2014.3-1.mga4
Show 5 moreShow less
Affected packages
PackageAffectedFixed
php5
Ubuntu:14.04:LTS
before 5.5.9+dfsg-1ubuntu4.1, plus listed versions
5.5.3+dfsg-1ubuntu25.5.3+dfsg-1ubuntu35.5.6+dfsg-1ubuntu15.5.6+dfsg-1ubuntu25.5.8+dfsg-2ubuntu1
Show 4 moreShow less
5.5.9+dfsg-1ubuntu15.5.9+dfsg-1ubuntu25.5.9+dfsg-1ubuntu35.5.9+dfsg-1ubuntu4
5.5.9+dfsg-1ubuntu4.1
php7
openSUSE:Tumbleweed
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
before 5.6.28-1.1
5.6.28-1.1
froxlor
openSUSE:Tumbleweed
before 0.9.38.4-1.1
0.9.38.4-1.1
php8
openSUSE:Tumbleweed
before 8.0.11-1.1
8.0.11-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-0185 is a high vulnerability (CVSS 7.2) in Php, published May 6, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in php5 5.4.4-14+deb7u10.

References

Show 132 moreShow less
MoveEnter Open