Every CVE Search/ Get API key

CVE-2014-3137

Bottle does not properly limit content-types

6.8 MediumFix available

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Exploit likelihood

3.13%Down 3.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
CVE-2014-3137
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
CVE-2014-3137
Updated
2026-11-02
EUVDEUVD-2014-0004 No score

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
EUVD-2014-0004
Updated
2026-11-03
GitHub AdvisoriesGHSA-873q-wpqr-xfgw 8.1

Bottle does not properly limit content-types

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
GHSA-873q-wpqr-xfgw
CVSS 4.0
8.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-873q-wpqr-xfgw 8.1

Bottle does not properly limit content-types

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
GHSA-873q-wpqr-xfgw
CVSS 4.0
8.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
CVE-2014-3137
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3137 No score

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
DEBIAN-CVE-2014-3137
Updated
2026-11-02
OSVPYSEC-2014-77 No score

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
PYSEC-2014-77
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3137 No score

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a ; (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Record
UBUNTU-CVE-2014-3137
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bottle
PyPI
0.10.0 up to 0.10.12
0.10.12
bottle
PyPI
0.11.0 up to 0.11.7
0.11.7
bottle
PyPI
0.12.0 up to 0.12.6
0.12.6
python-bottle
Debian:12
before 0.12.6-1
0.12.6-1
python-bottle
Debian:13
before 0.12.6-1
0.12.6-1
python-bottle
Debian:14
before 0.12.6-1
0.12.6-1
python-bottle
Debian:7
before 0.10.11-1+deb7u1, plus listed versions
0.10.11-1
0.10.11-1+deb7u1
bottle
PyPI
0.10.0 up to 0.10.12, plus listed versions
0.10.10.10.100.10.110.10.20.10.3
Show 6 moreShow less
0.10.40.10.50.10.60.10.70.10.80.10.9
0.10.12
bottle
PyPI
0.11.0 up to 0.11.7, plus listed versions
0.11.10.11.20.11.30.11.40.11.50.11.6
0.11.7
bottle
PyPI
0.12.0 up to 0.12.6, plus listed versions
0.12.10.12.20.12.30.12.40.12.5
0.12.6
bottle
PyPI
0.8 up to 0.10.12, 0.11 up to 0.11.7, 0.12 up to 0.12.6, plus listed versions
0.10.10.10.100.10.110.10.20.10.3
Show 30 moreShow less
0.10.40.10.50.10.60.10.70.10.80.10.90.11.10.11.20.11.30.11.40.11.50.11.60.12.10.12.20.12.30.12.40.12.50.8.10.8.20.8.30.8.40.8.50.9.10.9.20.9.30.9.40.9.50.9.60.9.70.9.8
0.10.120.11.70.12.6
python-bottle
Ubuntu:Pro:14.04:LTS
before 0.12.0-1ubuntu0.1~esm1, plus listed versions
0.11.6-10.12.0-1
0.12.0-1ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3137 is a medium vulnerability (CVSS 6.8) in Bottlepy Bottle, published June 4, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.13%, the 87th percentile. Fixed in bottle 0.10.12.

References

Show 6 moreShow less
MoveEnter Open