Every CVE Search/ Get API key

CVE-2014-8990

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary...

7.5 HighFix available

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Exploit likelihood

5.24%Up 3.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
CVE-2014-8990
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-77
Updated
2026-11-02
CVE List No score

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
CVE-2014-8990
Updated
2026-11-02
EUVDEUVD-2014-8817 No score

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
EUVD-2014-8817
Updated
2026-11-03
GitHub AdvisoriesGHSA-2jg7-cr9w-6gw3 No score

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary...

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
GHSA-2jg7-cr9w-6gw3
Weakness
CWE-77
Updated
2026-11-02
OSV No score

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
CVE-2014-8990
Updated
2026-11-02
OSVDEBIAN-CVE-2014-8990 No score

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
DEBIAN-CVE-2014-8990
Updated
2026-11-02
OSVUBUNTU-CVE-2014-8990 No score

default-rsyncssh.lua in Lsyncd 2.1.5 and earlier allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Record
UBUNTU-CVE-2014-8990
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lsyncd
Debian:12
before 2.1.5-2
2.1.5-2
lsyncd
Debian:13
before 2.1.5-2
2.1.5-2
lsyncd
Debian:7
before 2.0.7-3+deb7u1, plus listed versions
2.0.7-3
2.0.7-3+deb7u1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8990 is a high vulnerability (CVSS 7.5) in Lsyncd Project Lsyncd, published December 5, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.24%, the 92nd percentile. Fixed in lsyncd 2.1.5-2.

References

Show 10 moreShow less
MoveEnter Open