Every CVE Search/ Get API key

CVE-2014-3609

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to...

5.0 MediumFix available

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Exploit likelihood

56.2%Up 52.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
CVE-2014-3609
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
CVE-2014-3609
Updated
2026-11-02
EUVDEUVD-2014-3574 No score

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
EUVD-2014-3574
Updated
2026-11-03
GitHub AdvisoriesGHSA-wfpr-78ph-w6wr No score

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to...

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
GHSA-wfpr-78ph-w6wr
Weakness
CWE-20
Updated
2026-11-02
OSV No score

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
CVE-2014-3609
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3609 No score

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
DEBIAN-CVE-2014-3609
Updated
2026-11-02
OSVMGASA-2014-0369 No score

Updated squid packages fix CVE-2014-3609

Updated squid packages fix security vulnerability:

Matthew Daley discovered that Squid 3 did not properly perform input validation in request parsing. A remote attacker could send crafted Range requests to cause a denial of service (CVE-2014-3609).

Record
MGASA-2014-0369
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3609 No score

HttpHdrRange.cc in Squid 3.x before 3.3.12 and 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via a request with crafted "Range headers with unidentifiable byte-range values."

Record
UBUNTU-CVE-2014-3609
Updated
2026-11-02
OSVUSN-2327-1 No score

squid3 vulnerability

Matthew Daley discovered that Squid 3 did not properly perform input validation in request parsing. A remote attacker could send crafted Range requests to cause a denial of service.

Record
USN-2327-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squid
Debian:12
before 2.7.STABLE9-5
2.7.STABLE9-5
squid
Debian:13
before 2.7.STABLE9-5
2.7.STABLE9-5
squid
Debian:14
before 2.7.STABLE9-5
2.7.STABLE9-5
squid
Debian:6.0
before 2.7.STABLE9-2.1+deb6u1, plus listed versions
2.7.STABLE9-2.1
2.7.STABLE9-2.1+deb6u1
squid3
Debian:6.0
before 3.1.6-1.2+squeeze4, plus listed versions
3.1.6-1.23.1.6-1.2+squeeze13.1.6-1.2+squeeze23.1.6-1.2+squeeze3
3.1.6-1.2+squeeze4
squid3
Debian:7
before 3.1.20-2.2+deb7u2, plus listed versions
3.1.20-2.23.1.20-2.2+deb7u1
3.1.20-2.2+deb7u2
squid
Debian:7
before 2.7.STABLE9-4.1+deb7u1, plus listed versions
2.7.STABLE9-4.1
2.7.STABLE9-4.1+deb7u1
squid
Mageia:3
before 3.2.10-1.7.mga3
3.2.10-1.7.mga3
squid
Mageia:4
before 3.3.13-1.mga4
3.3.13-1.mga4
squid
Red Hat:enterprise_linux:7::server
before 7:3.3.8-12.el7_0
7:3.3.8-12.el7_0
Show 14 moreShow less
Affected packages
PackageAffectedFixed
squid-debuginfo
Red Hat:enterprise_linux:7::server
before 7:3.3.8-12.el7_0
7:3.3.8-12.el7_0
squid-sysvinit
Red Hat:enterprise_linux:7::server
before 7:3.3.8-12.el7_0
7:3.3.8-12.el7_0
squid
Red Hat:enterprise_linux:7::workstation
before 7:3.3.8-12.el7_0
7:3.3.8-12.el7_0
squid-debuginfo
Red Hat:enterprise_linux:7::workstation
before 7:3.3.8-12.el7_0
7:3.3.8-12.el7_0
squid-sysvinit
Red Hat:enterprise_linux:7::workstation
before 7:3.3.8-12.el7_0
7:3.3.8-12.el7_0
squid
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 2 CVEs
before 7:2.6.STABLE21-7.el5_10
7:2.6.STABLE21-7.el5_10
squid-debuginfo
Red Hat:enterprise_linux:5::client_workstation
From an advisory covering 2 CVEs
before 7:2.6.STABLE21-7.el5_10
7:2.6.STABLE21-7.el5_10
squid
Red Hat:enterprise_linux:5::server
From an advisory covering 2 CVEs
before 7:2.6.STABLE21-7.el5_10
7:2.6.STABLE21-7.el5_10
squid-debuginfo
Red Hat:enterprise_linux:5::server
From an advisory covering 2 CVEs
before 7:2.6.STABLE21-7.el5_10
7:2.6.STABLE21-7.el5_10
squid
Red Hat:enterprise_linux:6::server
From an advisory covering 2 CVEs
before 7:3.1.10-22.el6_5
7:3.1.10-22.el6_5
squid-debuginfo
Red Hat:enterprise_linux:6::server
From an advisory covering 2 CVEs
before 7:3.1.10-22.el6_5
7:3.1.10-22.el6_5
squid
Red Hat:enterprise_linux:6::workstation
From an advisory covering 2 CVEs
before 7:3.1.10-22.el6_5
7:3.1.10-22.el6_5
squid-debuginfo
Red Hat:enterprise_linux:6::workstation
From an advisory covering 2 CVEs
before 7:3.1.10-22.el6_5
7:3.1.10-22.el6_5
squid3
Ubuntu:14.04:LTS
before 3.3.8-1ubuntu6.1, plus listed versions
3.3.8-1ubuntu33.3.8-1ubuntu43.3.8-1ubuntu53.3.8-1ubuntu6
3.3.8-1ubuntu6.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3609 is a medium vulnerability (CVSS 5.0) in Squid-cache Squid, published August 28, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 56.2%, the 99th percentile. Fixed in squid 2.7.STABLE9-5.

References

Show 30 moreShow less
MoveEnter Open