CVE-2015-3337
Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
4.3
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
- Record
CVE-2015-3337- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
- Record
CVE-2015-3337- Updated
- 2026-11-02
EUVDEUVD-2022-5748 No score
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
- Record
EUVD-2022-5748- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x8q8-4hp5-463w No score
Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
- Record
GHSA-x8q8-4hp5-463w- Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-x8q8-4hp5-463w No score
Improper Limitation of a Pathname to a Restricted Directory in Elasticsearch
Directory traversal vulnerability in Elasticsearch before 1.4.5 and 1.5.x before 1.5.2, when a site plugin is enabled, allows remote attackers to read arbitrary files via unspecified vectors.
- Record
GHSA-x8q8-4hp5-463w- Weakness
- CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.elasticsearch:elasticsearchMaven |
through 1.4.4 | 1.4.5 |
org.elasticsearch:elasticsearchMaven |
1.5.0 to 1.5.1 | 1.5.2 |
elasticsearchDebian:8 |
before 1.0.3+dfsg-5+deb8u1, plus listed versions 1.0.3+dfsg-5 |
1.0.3+dfsg-5+deb8u1 |
org.elasticsearch:elasticsearchMaven |
before 1.4.5, plus listed versions 0.10.00.11.00.12.00.12.10.13.0 Show 45 moreShow less0.13.10.14.00.14.10.14.20.14.30.14.40.15.00.15.10.15.20.16.00.16.10.16.20.16.30.16.40.16.50.17.00.17.10.17.100.17.20.17.30.17.40.17.50.17.60.17.70.17.80.17.90.18.00.18.10.18.20.18.30.18.40.18.50.18.60.18.70.19.00.19.0.RC10.19.0.RC20.19.0.RC30.19.10.19.100.19.110.19.120.19.20.19.30.19.4 |
1.4.5 |
org.elasticsearch:elasticsearchMaven |
1.5.0 up to 1.5.2, plus listed versions 1.5.1 |
1.5.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | ElasticSearch < 1.4.5 / < 1.5.2 - Directory Traversal | 2015-05-18 |
| Nuclei | Elasticsearch - Local File Inclusion | |
| PoC in GitHub | jas502n/CVE-2015-3337 | 2019-06-21 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3337 is a medium vulnerability (CVSS 4.3) in Elasticsearch, published April 29, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 33.2%, the 98th percentile. Fixed in org.elasticsearch:elasticsearch 1.4.5.
References
securityfocus.com/bid/74353
packetstormsecurity.com/files/131646/Elasticsearch-Directory-Traversal.html
securityfocus.com/archive/1/535385
exploit-db.com/exploits/37054
elastic.co/community/security
debian.org/security/2015/dsa-3241
nvd.nist.gov/vuln/detail/CVE-2015-3337
github.com/advisories/GHSA-x8q8-4hp5-463w
Left out here: 67 versions. The JSON record has them.