CVE-2015-3451
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option...
CVE-2015-3451 is a medium vulnerability (CVSS 5.0) in Canonical Ubuntu Linux, published April 30, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.02%, the 90th percentile. Fixed in libxml-libxml-perl 2.0116+dfsg-2.
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
Exploit likelihood
What each source reports
NVD Score used
5.0
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
CVE-2015-3451- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
CVE List No score
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
CVE-2015-3451- Updated
- 2026-11-02
EUVDEUVD-2015-3494 No score
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
EUVD-2015-3494- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mrvg-p24w-mp92 No score
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option...
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
GHSA-mrvg-p24w-mp92- Weakness
- CWE-611
- Updated
- 2026-11-02
OSV No score
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
CVE-2015-3451- Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-3451 No score
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
DEBIAN-CVE-2015-3451- Updated
- 2026-11-02
Show 5 moreShow less
OSVMGASA-2015-0199 No score
Updated perl-XML-LibXML packages fix CVE-2015-3451
Updated perl-XML-LibXML package fixes security vulnerability:
Tilmann Haak from xing.com discovered that XML::LibXML did not respect the expand_entities parameter to disable processing of external entities in some circumstances. This may allow attackers to gain read access to otherwise protected ressources, depending on how the library is used (CVE-2015-3451).
- Record
MGASA-2015-0199- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10516-1 No score
perl-XML-LibXML-2.0128-1.3 on GA media
These are all security issues fixed in the perl-XML-LibXML-2.0128-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10516-1- Updated
- 2026-11-02
OSVSUSE-SU-2015:1439-1 No score
Security update for perl-XML-LibXML
perl-XML-LibXML was updated to fix the expand_entities option to be preserved in all cases. (CVE-2015-3451).
- Record
SUSE-SU-2015:1439-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-3451 No score
The _clone function in XML::LibXML before 2.0119 does not properly set the expand_entities option, which allows remote attackers to conduct XML external entity (XXE) attacks via crafted XML data to the (1) new or (2) load_xml function.
- Record
UBUNTU-CVE-2015-3451- Updated
- 2026-11-02
OSVUSN-2592-1 No score
libxml-libxml-perl vulnerability
Tilmann Haak discovered that XML::LibXML incorrectly handled the expand_entities parameter in certain situations. A remote attacker could possibly use this issue to access sensitive information.
- Record
USN-2592-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libxml-libxml-perlDebian:12 |
before 2.0116+dfsg-2 | 2.0116+dfsg-2 |
libxml-libxml-perlDebian:13 |
before 2.0116+dfsg-2 | 2.0116+dfsg-2 |
libxml-libxml-perlDebian:14 |
before 2.0116+dfsg-2 | 2.0116+dfsg-2 |
libxml-libxml-perlDebian:6.0 |
before 1.70.ds-1+deb6u1, plus listed versions 1.70.ds-1 |
1.70.ds-1+deb6u1 |
libxml-libxml-perlDebian:7 |
before 2.0001+dfsg-1+deb7u1, plus listed versions 2.0001+dfsg-1 |
2.0001+dfsg-1+deb7u1 |
libxml-libxml-perlDebian:8 |
before 2.0116+dfsg-1+deb8u1, plus listed versions 2.0116+dfsg-1 |
2.0116+dfsg-1+deb8u1 |
perl-XML-LibXMLMageia:4 |
before 2.10.0-2.1.mga4 | 2.10.0-2.1.mga4 |
perl-XML-LibXMLSUSE:Linux Enterprise Desktop 12 |
before 2.0019-5.3 | 2.0019-5.3 |
perl-XML-LibXMLSUSE:Linux Enterprise Server 12 |
before 2.0019-5.3 | 2.0019-5.3 |
perl-XML-LibXMLSUSE:Linux Enterprise Server for SAP Applications 12 |
before 2.0019-5.3 | 2.0019-5.3 |
libxml-libxml-perlUbuntu:14.04:LTS |
before 2.0108+dfsg-1ubuntu0.1, plus listed versions 2.0010+dfsg-12.0106+dfsg-12.0107+dfsg-12.0108+dfsg-1 |
2.0108+dfsg-1ubuntu0.1 |
perl-XML-LibXMLopenSUSE:Tumbleweed |
before 2.0128-1.3 | 2.0128-1.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
cpansearch.perl.org/src/SHLOMIF/XML-LibXML-2.0119/Changes
openwall.com/lists/oss-security/2015/04/30/1
bitbucket.org/shlomif/perl-xml-libxml/commits/5962fd067580767777e94640b129ae8930a68a30/raw
debian.org/security/2015/dsa-3243
lists.fedoraproject.org/pipermail/package-announce/2015-May/157448.html
lists.fedoraproject.org/pipermail/package-announce/2015-May/157740.html
Show 16 moreShow less
openwall.com/lists/oss-security/2015/04/25/2
lists.opensuse.org/opensuse-updates/2015-09/msg00006.html
mandriva.com/security/advisories?name=MDVSA-2015:231
ubuntu.com/usn/USN-2592-1
advisories.mageia.org/MGASA-2015-0199.html
securityfocus.com/bid/74333
nvd.nist.gov/vuln/detail/CVE-2015-3451
github.com/advisories/GHSA-mrvg-p24w-mp92
security-tracker.debian.org/tracker/CVE-2015-3451
bugs.mageia.org/show_bug.cgi?id=15803
suse.com/support/update/announcement/2015/suse-su-20151439-1
bugzilla.suse.com/929237
suse.com/security/cve/CVE-2015-3451
ubuntu.com/security/CVE-2015-3451
ubuntu.com/security/notices/USN-2592-1
cve.org/CVERecord?id=CVE-2015-3451