Every CVE Search/ Get API key

CVE-2015-2213

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in...

7.5 HighFix available

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Exploit likelihood

9.66%Up 7.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Record
CVE-2015-2213
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Record
CVE-2015-2213
Updated
2026-11-02
EUVDEUVD-2015-2320 No score

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Record
EUVD-2015-2320
Updated
2026-11-03
GitHub AdvisoriesGHSA-qq9g-jv5w-jh6w No score

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in...

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Record
GHSA-qq9g-jv5w-jh6w
Weakness
CWE-89
Updated
2026-11-02
OSV No score

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Record
CVE-2015-2213
Updated
2026-11-02
OSVDEBIAN-CVE-2015-2213 No score

SQL injection vulnerability in the wp_untrash_post_comments function in wp-includes/post.php in WordPress before 4.2.4 allows remote attackers to execute arbitrary SQL commands via a comment that is mishandled after retrieval from the trash.

Record
DEBIAN-CVE-2015-2213
Updated
2026-11-02
OSVMGASA-2015-0309 No score

Updated wordpress package fixes security vulnerability

The wordpress package has been updated to version 3.9.8, fixing three cross-site scripting issues (CVE-2015-5732, CVE-2015-5733, CVE-2015-5734), a potential timing side-channel attack in Customizer (CVe-2015-5730), an issue in Heartbeat where an attacker could lock a post from being edited (CVE-2015-5731), and an SQL injection issue (CVE-2015-2213), as well as other bugs. See the upstream announcement and release notes for more details.

Record
MGASA-2015-0309
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 4.2.4+dfsg-1
4.2.4+dfsg-1
wordpress
Debian:13
before 4.2.4+dfsg-1
4.2.4+dfsg-1
wordpress
Debian:14
before 4.2.4+dfsg-1
4.2.4+dfsg-1
wordpress
Debian:6.0
before 3.6.1+dfsg-1~deb6u7, plus listed versions
3.0.4+dfsg-13.0.5+dfsg-0+squeeze13.0.5+dfsg-13.2.1+dfsg-13.2.1+dfsg-2
Show 23 moreShow less
3.2.1+dfsg-33.3+dfsg-13.3.1+dfsg-13.3.2+dfsg-13.3.2+dfsg-1~squeeze13.4+dfsg-13.4+dfsg-23.4+dfsg-33.4.1+dfsg-13.4.2+dfsg-13.5+dfsg-13.5.1+dfsg-13.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-13.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u6
3.6.1+dfsg-1~deb6u7
wordpress
Debian:8
before 4.1+dfsg-1+deb8u4, plus listed versions
4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u24.1+dfsg-1+deb8u3
4.1+dfsg-1+deb8u4
wordpress
Debian:7
before 3.6.1+dfsg-1~deb7u8, plus listed versions
3.5.1+dfsg-23.5.2+dfsg-13.5.2+dfsg-1~deb6u13.5.2+dfsg-1~deb7u13.6+dfsg-1
Show 15 moreShow less
3.6.1+dfsg-1~deb6u13.6.1+dfsg-1~deb6u23.6.1+dfsg-1~deb6u33.6.1+dfsg-1~deb6u43.6.1+dfsg-1~deb6u53.6.1+dfsg-1~deb6u63.6.1+dfsg-1~deb6u73.6.1+dfsg-1~deb6u83.6.1+dfsg-1~deb6u93.6.1+dfsg-1~deb7u13.6.1+dfsg-1~deb7u23.6.1+dfsg-1~deb7u33.6.1+dfsg-1~deb7u43.6.1+dfsg-1~deb7u53.6.1+dfsg-1~deb7u6
3.6.1+dfsg-1~deb7u8
wordpress
Mageia:4
before 3.9.8-1.mga4
3.9.8-1.mga4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-2213 is a high vulnerability (CVSS 7.5) in Wordpress, published August 10, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.66%, the 95th percentile. Fixed in wordpress 4.2.4+dfsg-1.

References

Show 10 moreShow less
MoveEnter Open