Every CVE Search/ Get API key

CVE-2016-2851

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to...

9.8 CriticalPublic exploitFix available

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

24.3%Down 12.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
CVE-2016-2851
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
CVE-2016-2851
Updated
2026-11-02
EUVDEUVD-2016-3924 No score

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
EUVD-2016-3924
Updated
2026-11-03
GitHub AdvisoriesGHSA-p3jg-fm9x-hc9c 9.8

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to...

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
GHSA-p3jg-fm9x-hc9c
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
CVE-2016-2851
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-2851 9.8

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
DEBIAN-CVE-2016-2851
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2016-2851 9.8

Integer overflow in proto.c in libotr before 4.1.1 on 64-bit platforms allows remote attackers to cause a denial of service (memory corruption and application crash) or execute arbitrary code via a series of large OTR messages, which triggers a heap-based buffer overflow.

Record
UBUNTU-CVE-2016-2851
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0117 No score

Updated libotr packages fix security vulnerability

A remote attacker may crash or execute arbitrary code in libotr before 4.1.1 by sending large OTR messages. While processing specially crafted messages, attacker controlled data on the heap is written out of bounds (CVE-2016-2851).

Record
MGASA-2016-0117
Updated
2026-11-02
OSVopenSUSE-SU-2024:10546-1 No score

libotr-devel-4.1.1-1.6 on GA media

These are all security issues fixed in the libotr-devel-4.1.1-1.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10546-1
Updated
2026-11-02
OSVSUSE-SU-2016:0706-1 No score

Security update for libotr

This update for libotr fixes the following issues:

  • Apply 'libotr-CVE-2016-2851.patch' to fix integer overflows that used to occur on 64-bit architectures when receiving 4GB messages. This flaw could potentially have been exploited by an attacker to remotely execute arbitrary code on the user's machine. (CVE-2016-2851, bsc#969785)
Record
SUSE-SU-2016:0706-1
Updated
2026-11-02
OSVSUSE-SU-2016:0707-1 No score

Security update for libotr

This update for libotr fixes the following issue:

  • Apply 'libotr-CVE-2016-2851.patch' to fix integer overflows that used to occur on 64-bit architectures when receiving 4GB messages. This flaw could potentially have been exploited by an attacker to remotely execute arbitrary code on the user's machine
    • (CVE-2016-2851, bsc#969785)
Record
SUSE-SU-2016:0707-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libotr
Debian:12
before 4.1.1-1
4.1.1-1
libotr
Debian:13
before 4.1.1-1
4.1.1-1
libotr
Debian:14
before 4.1.1-1
4.1.1-1
libotr
Debian:7
before 3.2.1-1+deb7u2, plus listed versions
3.2.1-13.2.1-1+deb7u1
3.2.1-1+deb7u2
libotr
Debian:8
before 4.1.0-2+deb8u1, plus listed versions
4.1.0-24.1.0-2+deb8u1~bpo70+1
4.1.0-2+deb8u1
libotr
Mageia:5
before 4.1.1-1.mga5
4.1.1-1.mga5
libotr
SUSE:Linux Enterprise Software Development Kit 11 SP4
before 3.2.0-10.5.1
3.2.0-10.5.1
libotr
SUSE:Linux Enterprise Desktop 11 SP4
before 3.2.0-10.5.1
3.2.0-10.5.1
libotr
SUSE:Linux Enterprise Server 11 SP4
before 3.2.0-10.5.1
3.2.0-10.5.1
libotr
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 3.2.0-10.5.1
3.2.0-10.5.1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
libotr
SUSE:Linux Enterprise Desktop 12
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Desktop 12 SP1
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Software Development Kit 12
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Software Development Kit 12 SP1
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Server 12
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Server for SAP Applications 12
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Server 12 SP1
before 4.0.0-9.1
4.0.0-9.1
libotr
SUSE:Linux Enterprise Server for SAP Applications 12 SP1
before 4.0.0-9.1
4.0.0-9.1
libotr
Ubuntu:14.04:LTS
before 4.0.0-2.2ubuntu1.1, plus listed versions
4.0.0-2.24.0.0-2.2ubuntu1
4.0.0-2.2ubuntu1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBlibotr 4.1.0 - Memory Corruption2016-03-10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-2851 is a critical vulnerability (CVSS 9.8) in Cypherpunks Libotr, published March 9, 2016. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 24.3%, the 97th percentile. Fixed in libotr 4.1.1-1.

References

Show 17 moreShow less
MoveEnter Open