Every CVE Search/ Get API key

CVE-2015-8833

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the...

9.8 CriticalFix available

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

7.03%Down 3.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
CVE-2015-8833
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
CVE-2015-8833
Updated
2026-11-02
EUVDEUVD-2015-8699 No score

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
EUVD-2015-8699
Updated
2026-11-03
GitHub AdvisoriesGHSA-r9f9-6pf9-r2c4 9.8

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the...

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
GHSA-r9f9-6pf9-r2c4
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
CVE-2015-8833
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2015-8833 9.8

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
DEBIAN-CVE-2015-8833
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2015-8833 9.8

Use-after-free vulnerability in the create_smp_dialog function in gtk-dialog.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 4.0.2 for Pidgin allows remote attackers to execute arbitrary code via vectors related to the "Authenticate buddy" menu item.

Record
UBUNTU-CVE-2015-8833
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0125 No score

Updated pidgin-otr packages fix security vulnerability

The pidgin-otr plugin before 4.0.2 is vulnerable to a heap use after free error. The bug is triggered when a user tries to authenticate a buddy and happens in the function create_smp_dialog (CVE-2015-8833).

Record
MGASA-2016-0125
Updated
2026-11-02
OSVopenSUSE-SU-2024:10258-1 No score

pidgin-otr-4.0.2-1.5 on GA media

These are all security issues fixed in the pidgin-otr-4.0.2-1.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10258-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11173-1 No score

pidgin-plugin-otr-4.0.2-3.18 on GA media

These are all security issues fixed in the pidgin-plugin-otr-4.0.2-3.18 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11173-1
Updated
2026-11-02
OSVSUSE-SU-2016:0912-1 No score

Security update for pidgin-otr

This update for pidgin-otr fixes the following issues:

  • CVE-2015-8833: A heap based use-after-free issue was fixed in pidgin-otr that could lead to crashes or potential code execution.
Record
SUSE-SU-2016:0912-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pidgin-otr
Debian:12
before 4.0.2-1
4.0.2-1
pidgin-otr
Debian:13
before 4.0.2-1
4.0.2-1
pidgin-otr
Debian:8
before 4.0.1-1+deb8u1, plus listed versions
4.0.1-1
4.0.1-1+deb8u1
pidgin-otr
Mageia:5
before 4.0.2-1.mga5
4.0.2-1.mga5
pidgin-otr
SUSE:Linux Enterprise Desktop 12
before 4.0.0-8.1
4.0.0-8.1
pidgin-otr
SUSE:Linux Enterprise Desktop 12 SP1
before 4.0.0-8.1
4.0.0-8.1
pidgin-otr
SUSE:Linux Enterprise Workstation Extension 12
before 4.0.0-8.1
4.0.0-8.1
pidgin-otr
SUSE:Linux Enterprise Workstation Extension 12 SP1
before 4.0.0-8.1
4.0.0-8.1
pidgin-otr
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 4.0.2-1.5
4.0.2-1.5

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-8833 is a critical vulnerability (CVSS 9.8) in Cypherpunks Pidgin-otr, published March 23, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.03%, the 94th percentile. Fixed in pidgin-otr 4.0.2-1.

References

Show 18 moreShow less
MoveEnter Open