Every CVE Search/ Get API key

CVE-2016-4478

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in...

7.5 HighFix available

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.27%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
CVE-2016-4478
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
CVE-2016-4478
Updated
2026-11-02
EUVDEUVD-2016-5465 No score

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
EUVD-2016-5465
Updated
2026-11-03
GitHub AdvisoriesGHSA-f9c4-56cj-69qg 7.5

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in...

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
GHSA-f9c4-56cj-69qg
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 7.5

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
CVE-2016-4478
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-4478 7.5

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
DEBIAN-CVE-2016-4478
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-4478 7.5

Buffer overflow in the xmlrpc_char_encode function in modules/transport/xmlrpc/xmlrpclib.c in Atheme before 7.2.7 allows remote attackers to cause a denial of service via vectors related to XMLRPC response encoding.

Record
UBUNTU-CVE-2016-4478
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10515-1 No score

atheme-7.2.7-1.1 on GA media

These are all security issues fixed in the atheme-7.2.7-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10515-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
atheme-services
Debian:12
before 7.0.7-2
7.0.7-2
atheme-services
Debian:13
before 7.0.7-2
7.0.7-2
atheme-services
Debian:14
before 7.0.7-2
7.0.7-2
atheme-services
Debian:8
before 6.0.11-2+deb8u1, plus listed versions
6.0.11-2
6.0.11-2+deb8u1
atheme-services
Ubuntu:16.04:LTS
before 6.0.11-2+deb8u1build0.16.04.1, plus listed versions
6.0.11-2
6.0.11-2+deb8u1build0.16.04.1
atheme
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 7.2.7-1.1
7.2.7-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-4478 is a high vulnerability (CVSS 7.5) in Atheme, published May 23, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. Fixed in atheme-services 7.0.7-2.

References

Show 6 moreShow less
MoveEnter Open