Every CVE Search/ Get API key

CVE-2016-5108

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media...

9.8 CriticalPublic exploitFix available

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

24.7%Up 9.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
CVE-2016-5108
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
CVE-2016-5108
Updated
2026-11-02
EUVDEUVD-2016-6059 No score

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
EUVD-2016-6059
Updated
2026-11-03
GitHub AdvisoriesGHSA-w8h4-xfpc-5gq9 9.8

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media...

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
GHSA-w8h4-xfpc-5gq9
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
CVE-2016-5108
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-5108 9.8

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
DEBIAN-CVE-2016-5108
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-5108 9.8

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

Record
UBUNTU-CVE-2016-5108
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0221 No score

Updated vlc/mad packages fix security vulnerability

A vulnerability was found in processing QuickTime IMA files. VLC does not check that the number of channels in the input stream is less than or equal to the size of the buffer, resulting in an out-of-bounds write potential for remote code execution via a malicious media file (CVE-2016-5108).

The vlc package has been updated to version 2.2.4, which fixes this issue and other bugs.

Also, the mad package has been patched to fix an out-of-bounds write which could cause VLC or other applications linked to that library to crash on an invalid mp3 file.

Record
MGASA-2016-0221
Updated
2026-11-02
OSVopenSUSE-SU-2024:10064-1 No score

libvlc5-2.2.4-11.1 on GA media

These are all security issues fixed in the libvlc5-2.2.4-11.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10064-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vlc
Debian:12
before 2.2.3-2
2.2.3-2
vlc
Debian:13
before 2.2.3-2
2.2.3-2
vlc
Debian:14
before 2.2.3-2
2.2.3-2
vlc
Debian:8
before 2.2.4-1~deb8u1, plus listed versions
2.2.0-12.2.0~rc2-22.2.0~rc2-2+deb8u12.2.1-12.2.1-1~deb8u1
Show 12 moreShow less
2.2.1-22.2.1-32.2.1-42.2.1-52.2.2-12.2.2-22.2.2-32.2.2-42.2.2-52.2.2-62.2.3-12.2.3-2
2.2.4-1~deb8u1
mad
Mageia:5
before 0.15.1b-16.1.mga5
0.15.1b-16.1.mga5
vlc
Mageia:5
before 2.2.4-1.mga5
2.2.4-1.mga5
vlc
Mageia:5
before 2.2.4-1.mga5.tainted
2.2.4-1.mga5.tainted
vlc
Ubuntu:14.04:LTS
before 2.1.6-0ubuntu14.04.3, plus listed versions
2.0.8-12.1.1-12.1.2-12.1.2-22.1.2-2build1
Show 4 moreShow less
2.1.2-2build22.1.4-0ubuntu14.04.12.1.6-0ubuntu14.04.12.1.6-0ubuntu14.04.2
2.1.6-0ubuntu14.04.3
vlc
Ubuntu:16.04:LTS
before 2.2.2-5ubuntu0.16.04.3, plus listed versions
2.2.1-32.2.1-52.2.2-12.2.2-22.2.2-3
Show 5 moreShow less
2.2.2-3build12.2.2-42.2.2-52.2.2-5ubuntu0.16.04.12.2.2-5ubuntu0.16.04.2
2.2.2-5ubuntu0.16.04.3
vlc
openSUSE:Tumbleweed
before 2.2.4-11.1
2.2.4-11.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBVideoLAN VLC Media Player 2.2.1 - 'DecodeAdpcmImaQT' Buffer Overflow2016-05-27

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-5108 is a critical vulnerability (CVSS 9.8) in Videolan Vlc Media Player, published June 7, 2016. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 24.7%, the 97th percentile. Fixed in vlc 2.2.3-2.

References

Show 18 moreShow less
MoveEnter Open