CVE-2017-5938
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC...
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
- Record
CVE-2017-5938- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
- Record
CVE-2017-5938- Updated
- 2026-11-02
EUVDEUVD-2017-15010 No score
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
- Record
EUVD-2017-15010- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3h2f-w6h5-7wr8
6.1
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC...
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
- Record
GHSA-3h2f-w6h5-7wr8- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
- Record
CVE-2017-5938- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-5938
6.1
Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.
- Record
UBUNTU-CVE-2017-5938- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVMGASA-2017-0048 No score
Updated viewvc packages fix security vulnerability
Thomas Gerbet discovered that viewvc, a web interface for CVS and Subversion repositories, did not properly sanitize user input. This problem resulted in a potential Cross-Site Scripting vulnerability (CVE-2017-5938).
The viewvc package has been updated to version 1.1.26 which fixes this issue.
- Record
MGASA-2017-0048- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:12857-1 No score
viewvc-1.3.0~dev20230104-1.1 on GA media
These are all security issues fixed in the viewvc-1.3.0~dev20230104-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:12857-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
viewvcDebian:7 |
before 1.1.5-1.4+deb7u1, plus listed versions 1.1.5-1.4 |
1.1.5-1.4+deb7u1 |
viewvcDebian:8 |
before 1.1.22-1+deb8u1, plus listed versions 1.1.22-1 |
1.1.22-1+deb8u1 |
viewvcMageia:5 |
before 1.1.26-1.mga5 | 1.1.26-1.mga5 |
viewvcUbuntu:14.04:LTS |
before 1.1.5-1.4+deb7u1build0.14.04.1, plus listed versions 1.1.5-1.4 |
1.1.5-1.4+deb7u1build0.14.04.1 |
viewvcUbuntu:16.04:LTS |
before 1.1.22-1+deb8u1build0.16.04.1, plus listed versions 1.1.22-1 |
1.1.22-1+deb8u1build0.16.04.1 |
viewvcopenSUSE:Tumbleweed |
before 1.3.0~dev20230104-1.1 | 1.3.0~dev20230104-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-5938 is a medium vulnerability (CVSS 6.1) in Viewvc, published February 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.32%, the 70th percentile. Fixed in viewvc 1.1.5-1.4+deb7u1.
References
github.com/viewvc/viewvc/releases/tag/1.0.14
github.com/viewvc/viewvc/issues/137
securityfocus.com/bid/96185
github.com/viewvc/viewvc/commit/9dcfc7daa4c940992920d3b2fbd317da20e44aad
github.com/viewvc/viewvc/releases/tag/1.1.26
openwall.com/lists/oss-security/2017/02/09/6
Show 11 moreShow less
debian.org/security/2017/dsa-3784
lists.opensuse.org/opensuse-updates/2017-02/msg00082.html
nvd.nist.gov/vuln/detail/CVE-2017-5938
github.com/advisories/GHSA-3h2f-w6h5-7wr8
advisories.mageia.org/MGASA-2017-0048.html
bugs.mageia.org/show_bug.cgi?id=20262
ubuntu.com/security/CVE-2017-5938
openwall.com/lists/oss-security/2017/02/08/7
cve.org/CVERecord?id=CVE-2017-5938
suse.com/security/cve/CVE-2017-5938
suse.com/security/cve/CVE-2020-5283