Every CVE Search/ Get API key

CVE-2017-8911

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This...

9.8 CriticalFix available

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.93%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
CVE-2017-8911
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-191
Updated
2026-11-02
CVE List No score

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
CVE-2017-8911
Updated
2026-11-02
EUVDEUVD-2017-17851 No score

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
EUVD-2017-17851
Updated
2026-11-03
GitHub AdvisoriesGHSA-575j-8r4j-2fmq 9.8

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This...

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
GHSA-575j-8r4j-2fmq
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-191
Updated
2026-11-02
OSV 9.8

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
CVE-2017-8911
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-8911 9.8

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
DEBIAN-CVE-2017-8911
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-8911 9.8

An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14. This might lead to invalid write operations, controlled by an attacker.

Record
UBUNTU-CVE-2017-8911
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0209 No score

Updated tnef packages fix security vulnerability

It was discovered that tnef did not correctly validate its input. An attacker could exploit this by tricking a user into opening a malicious attachment, which would result in a denial-of-service by application crash (CVE-2017-8911).

Record
MGASA-2017-0209
Updated
2026-11-02
OSVopenSUSE-SU-2024:11467-1 No score

tnef-1.4.18-1.6 on GA media

These are all security issues fixed in the tnef-1.4.18-1.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11467-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
tnef
Debian:12
before 1.4.12-1.2
1.4.12-1.2
tnef
Debian:13
before 1.4.12-1.2
1.4.12-1.2
tnef
Debian:14
before 1.4.12-1.2
1.4.12-1.2
tnef
Debian:7
before 1.4.9-1+deb7u3, plus listed versions
1.4.9-11.4.9-1+deb7u11.4.9-1+deb7u2
1.4.9-1+deb7u3
tnef
Debian:8
before 1.4.9-1+deb8u3, plus listed versions
1.4.9-11.4.9-1+deb8u11.4.9-1+deb8u2
1.4.9-1+deb8u3
tnef
Mageia:5
before 1.4.15-1.mga5
1.4.15-1.mga5
tnef
Ubuntu:14.04:LTS
before 1.4.9-1+deb8u3build0.14.04.1, plus listed versions
1.4.9-11.4.9-1+deb8u2build0.14.04.1
1.4.9-1+deb8u3build0.14.04.1
tnef
Ubuntu:16.04:LTS
before 1.4.9-1+deb8u3build0.16.04.1, plus listed versions
1.4.9-11.4.9-1+deb8u2build0.16.04.1
1.4.9-1+deb8u3build0.16.04.1
tnef
openSUSE:Tumbleweed
before 1.4.18-1.6
1.4.18-1.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-8911 is a critical vulnerability (CVSS 9.8) in Tnef Project Tnef, published May 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.93%, the 80th percentile. Fixed in tnef 1.4.12-1.2.

References

Show 5 moreShow less
MoveEnter Open