Every CVE Search/ Get API key

CVE-2017-11721

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of...

9.8 CriticalFix available

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.52%Up 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
CVE-2017-11721
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
CVE-2017-11721
Updated
2026-11-02
EUVDEUVD-2017-3331 No score

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
EUVD-2017-3331
Updated
2026-11-03
GitHub AdvisoriesGHSA-22r2-8jr8-3hmr 9.8

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of...

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
GHSA-22r2-8jr8-3hmr
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 9.8

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
CVE-2017-11721
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-11721 9.8

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
DEBIAN-CVE-2017-11721
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-11721 9.8

Buffer overflow in ioquake3 before 2017-08-02 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted packet.

Record
UBUNTU-CVE-2017-11721
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0148 No score

Updated ioquake3 packages fix security vulnerability

It was discovered that ioquake3 contained a read buffer overflow that allows remote attackers to cause a denial of service (CVE-2017-11721).

Record
MGASA-2018-0148
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ioquake3
Debian:12
before 1.36+u20170803+dfsg1-1
1.36+u20170803+dfsg1-1
ioquake3
Debian:13
before 1.36+u20170803+dfsg1-1
1.36+u20170803+dfsg1-1
ioquake3
Debian:14
before 1.36+u20170803+dfsg1-1
1.36+u20170803+dfsg1-1
iortcw
Debian:12
before 1.51+dfsg1-3, plus listed versions
1.42b+20150930+dfsg1-11.42b+20151119+dfsg1-11.42d+dfsg1-11.42d+dfsg1-21.42d+dfsg1-3
Show 7 moreShow less
1.42d+dfsg1-41.42d+dfsg1-51.50a+dfsg1-11.50a+dfsg1-21.50a+dfsg1-31.51+dfsg1-11.51+dfsg1-2
1.51+dfsg1-3
iortcw
Debian:13
before 1.51+dfsg1-3, plus listed versions
1.42b+20150930+dfsg1-11.42b+20151119+dfsg1-11.42d+dfsg1-11.42d+dfsg1-21.42d+dfsg1-3
Show 7 moreShow less
1.42d+dfsg1-41.42d+dfsg1-51.50a+dfsg1-11.50a+dfsg1-21.50a+dfsg1-31.51+dfsg1-11.51+dfsg1-2
1.51+dfsg1-3
iortcw
Debian:14
before 1.51+dfsg1-3, plus listed versions
1.42b+20150930+dfsg1-11.42b+20151119+dfsg1-11.42d+dfsg1-11.42d+dfsg1-21.42d+dfsg1-3
Show 7 moreShow less
1.42d+dfsg1-41.42d+dfsg1-51.50a+dfsg1-11.50a+dfsg1-21.50a+dfsg1-31.51+dfsg1-11.51+dfsg1-2
1.51+dfsg1-3
iortcw
Debian:9
before 1.50a+dfsg1-3+deb9u1, plus listed versions
1.42b+20150930+dfsg1-11.42b+20151119+dfsg1-11.42d+dfsg1-11.42d+dfsg1-21.42d+dfsg1-3
Show 5 moreShow less
1.42d+dfsg1-41.42d+dfsg1-51.50a+dfsg1-11.50a+dfsg1-21.50a+dfsg1-3
1.50a+dfsg1-3+deb9u1
ioquake3
Debian:8
before 1.36+u20140802+gca9eebb-2+deb8u2, plus listed versions
1.36+u20140802+gca9eebb-21.36+u20140802+gca9eebb-2+deb8u1
1.36+u20140802+gca9eebb-2+deb8u2
ioquake3
Debian:9
before 1.36+u20161101+dfsg1-2+deb9u1, plus listed versions
1.36+u20161101+dfsg1-2
1.36+u20161101+dfsg1-2+deb9u1
ioquake3
Mageia:6
before 1.36-12.20170428.1.1.mga6
1.36-12.20170428.1.1.mga6
ioquake3
Ubuntu:16.04:LTS
All versions, plus listed versions
1.36+u20150710+dfsg1-11.36+u20150926+dfsg1-11.36+u20151017+dfsg1-11.36+u20160122+dfsg1-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-11721 is a critical vulnerability (CVSS 9.8) in Ioquake3, published August 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.52%, the 84th percentile. Fixed in ioquake3 1.36+u20170803+dfsg1-1.

References

Show 4 moreShow less
MoveEnter Open