Every CVE Search/ Get API key

CVE-2017-11185

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service ...

7.5 HighFix available

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.83%Up 1.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
CVE-2017-11185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
EUVDEUVD-2017-2819 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
EUVD-2017-2819
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-6hcq-7fxg-hvvv 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service ...

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
GHSA-6hcq-7fxg-hvvv
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
NVD 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
CVE-2017-11185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
OSVALPINE-CVE-2017-11185 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
ALPINE-CVE-2017-11185
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
CVE-2017-11185
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2017-11185 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
DEBIAN-CVE-2017-11185
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-11185 7.5

The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.

Record
UBUNTU-CVE-2017-11185
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11411-1 No score

strongswan-5.9.0-1.9 on GA media

These are all security issues fixed in the strongswan-5.9.0-1.9 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11411-1
Updated
2026-11-02
OSVSUSE-SU-2017:2143-1 No score

Security update for strongswan

This update for strongswan fixes the following issues:

CVE-2017-11185: Specific RSA signatures passed to the gmp plugin for verification can cause a null-pointer dereference and it may lead to a denial of service (bsc#1051222)

Record
SUSE-SU-2017:2143-1
Updated
2026-11-02
OSVSUSE-SU-2017:2293-1 No score

Security update for strongswan

This update for strongswan fixes the following issues:

  • CVE-2017-11185: Specific RSA signatures passed to the gmp plugin for verification can cause a null-pointer dereference and it may lead to a denial of service (bsc#1051222)
Record
SUSE-SU-2017:2293-1
Updated
2026-11-02
OSVUSN-3397-1 No score

strongswan vulnerability

It was discovered that strongSwan incorrectly handled verifying specific RSA signatures. A remote attacker could use this issue to cause strongSwan to crash, resulting in a denial of service.

Record
USN-3397-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
strongswan
Alpine:v3.3
before 5.3.5-r4
5.3.5-r4
strongswan
Alpine:v3.4
before 5.4.0-r3
5.4.0-r3
strongswan
Alpine:v3.5
before 5.5.3-r1
5.5.3-r1
strongswan
Alpine:v3.6
before 5.5.3-r1
5.5.3-r1
strongswan
Debian:12
before 5.6.0-1
5.6.0-1
strongswan
Debian:13
before 5.6.0-1
5.6.0-1
strongswan
Debian:14
before 5.6.0-1
5.6.0-1
strongswan
Debian:7
before 4.5.2-1.5+deb7u10, plus listed versions
4.5.2-1.5+deb7u14.5.2-1.5+deb7u24.5.2-1.5+deb7u2~bpo60+14.5.2-1.5+deb7u34.5.2-1.5+deb7u3~bpo60+1
Show 5 moreShow less
4.5.2-1.5+deb7u44.5.2-1.5+deb7u64.5.2-1.5+deb7u74.5.2-1.5+deb7u84.5.2-1.5+deb7u9
4.5.2-1.5+deb7u10
strongswan
Debian:8
before 5.2.1-6+deb8u5, plus listed versions
5.2.1-65.2.1-6+deb8u15.2.1-6+deb8u1~bpo70+15.2.1-6+deb8u25.2.1-6+deb8u2~bpo70+15.2.1-6+deb8u35.2.1-6+deb8u4
5.2.1-6+deb8u5
strongswan
Debian:9
before 5.5.1-4+deb9u1, plus listed versions
5.5.1-4
5.5.1-4+deb9u1
Show 12 moreShow less
Affected packages
PackageAffectedFixed
strongswan
SUSE:Linux Enterprise Desktop 12 SP2
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Desktop 12 SP3
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Server 12 SP2
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Server for SAP Applications 12 SP2
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Server 12 SP3
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 5.1.3-26.5.1
5.1.3-26.5.1
strongswan
SUSE:Linux Enterprise Server 11 SP4
before 4.4.0-6.36.3.1
4.4.0-6.36.3.1
strongswan
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 4.4.0-6.36.3.1
4.4.0-6.36.3.1
strongswan
Ubuntu:14.04:LTS
before 5.1.2-0ubuntu2.7, plus listed versions
4.6.4-95.1.0-25.1.0-35.1.1-0ubuntu15.1.1-0ubuntu2
Show 18 moreShow less
5.1.1-0ubuntu35.1.1-0ubuntu45.1.1-0ubuntu55.1.1-0ubuntu75.1.1-0ubuntu145.1.1-0ubuntu175.1.2~dr3+git20130120-0ubuntu25.1.2~dr3+git20130120-0ubuntu35.1.2~rc1-0ubuntu35.1.2~rc1-0ubuntu45.1.2~rc2-0ubuntu25.1.2-0ubuntu15.1.2-0ubuntu25.1.2-0ubuntu2.25.1.2-0ubuntu2.35.1.2-0ubuntu2.45.1.2-0ubuntu2.55.1.2-0ubuntu2.6
5.1.2-0ubuntu2.7
strongswan
Ubuntu:16.04:LTS
before 5.3.5-1ubuntu3.4, plus listed versions
5.1.2-0ubuntu65.1.2-0ubuntu75.1.2-0ubuntu85.3.5-1ubuntu15.3.5-1ubuntu2
Show 4 moreShow less
5.3.5-1ubuntu35.3.5-1ubuntu3.15.3.5-1ubuntu3.25.3.5-1ubuntu3.3
5.3.5-1ubuntu3.4
strongswan
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 5.9.0-1.9
5.9.0-1.9

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-11185 is a high vulnerability (CVSS 7.5) in Strongswan, published August 11, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.83%, the 86th percentile. Fixed in strongswan 5.3.5-r4.

References

Show 15 moreShow less
MoveEnter Open