Every CVE Search/ Get API key

CVE-2017-1000256

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no"...

8.1 HighFix available

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.71%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
CVE-2017-1000256
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
CVE-2017-1000256
Updated
2026-11-02
EUVDEUVD-2017-1517 No score

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
EUVD-2017-1517
Updated
2026-11-03
GitHub AdvisoriesGHSA-gq8m-rwgg-6vv3 8.1

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no"...

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
GHSA-gq8m-rwgg-6vv3
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSVALPINE-CVE-2017-1000256 8.1

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
ALPINE-CVE-2017-1000256
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBELL-CVE-2017-1000256 8.1

CVE-2017-1000256 does not affect BellSoft software

Record
BELL-CVE-2017-1000256
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSV 8.1

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
CVE-2017-1000256
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-1000256 8.1

libvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.

Record
DEBIAN-CVE-2017-1000256
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0153 No score

Updated libvirt packages fix security vulnerabilities

Updated libvirt packages fix security vulnerabilities:

In virsh, the hostname could crafted maliciously with ssh arguments, which would be passed to ssh (bsc#1053600).

The default_tls_x509_verify (and related) parameters in qemu.conf control whether the TLS servers in QEMU request & verify certificates from clients. This works as a simple access control system for QEMU servers by requiring the CA to issue certs to permitted clients. This use of client certificates is disabled by default, since it requires extra work to issue client certificates. Unfortunately the libvirt code was using these configuration parameters when setting up both TLS clients and servers in QEMU. The result was that TLS clients for character devices and disk devices had verification turned off, meaning they would ignore any errors while validating the server certificate (CVE-2017-1000256).

An industry-wide issue was found in the way many modern microprocessor designs have implemented speculative execution of instructions (a commonly used performance optimization). There are three primary variants of the issue which differ in the way the speculative execution can be exploited. Variant CVE-2017-5715 triggers the speculative execution by utilizing branch target injection. It relies on the presence of a precisely-defined instruction sequence in the privileged code as well as the fact that memory accesses may cause allocation into the microprocessor's data cache even for speculatively executed instructions that never actually commit (retire). As a result, an unprivileged attacker could use this flaw to cross the syscall and guest/host boundaries and read privileged memory by conducting targeted cache side-channel attacks (CVE-2017-5715).

qemu/qemu_monitor.c in libvirt allows attackers to cause a denial of service (memory consumption) via a large QEMU reply (CVE-2018-5748).

It was discovered libvirt does not properly determine the hostname on LXC container startup, which allows local guest OS users to bypass an intended container protection mechanism and execute arbitrary commands via a crafted NSS module (CVE-2018-6764).

Record
MGASA-2018-0153
Updated
2026-11-02
OSVopenSUSE-SU-2024:11008-1 No score

libvirt-7.7.0-2.1 on GA media

These are all security issues fixed in the libvirt-7.7.0-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11008-1
Updated
2026-11-02
OSVSUSE-SU-2017:2850-1 No score

Security update for libvirt

This update for libvirt fixes the following issues:

Security issue fixed:

  • CVE-2017-1000256: Ensure TLS clients always verify the server certificate in the serial/TLS support. (bsc#1062563)

Non security issue fixed:

  • libvirt-daemon-qemu requires libvirt-daemon-driver-storage (bsc#1062620)
Record
SUSE-SU-2017:2850-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libvirt
Alpine:v3.5
2.3.0 up to 2.5.0-r2
2.5.0-r2
libvirt
Alpine:v3.6
2.3.0 up to 3.3.0-r2
3.3.0-r2
libvirt
Debian:12
before 3.8.0-3
3.8.0-3
libvirt
Debian:13
before 3.8.0-3
3.8.0-3
libvirt
Debian:14
before 3.8.0-3
3.8.0-3
libvirt
Debian:9
before 3.0.0-4+deb9u1, plus listed versions
3.0.0-4
3.0.0-4+deb9u1
libvirt
Mageia:6
From an advisory covering 4 CVEs
before 3.10.0-1.1.mga6
3.10.0-1.1.mga6
python-libvirt
Mageia:6
From an advisory covering 4 CVEs
before 3.10.0-1.mga6
3.10.0-1.mga6
libvirt
SUSE:Linux Enterprise Desktop 12 SP3
before 3.3.0-5.8.1
3.3.0-5.8.1
libvirt
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 3.3.0-5.8.1
3.3.0-5.8.1
libvirt
SUSE:Linux Enterprise Server 12 SP3
before 3.3.0-5.8.1
3.3.0-5.8.1
libvirt
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 3.3.0-5.8.1
3.3.0-5.8.1
libvirt
openSUSE:Tumbleweed
From an advisory covering 21 CVEs
before 7.7.0-2.1
7.7.0-2.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-1000256 is a high vulnerability (CVSS 8.1) in Redhat Libvirt, published October 19, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.71%, the 77th percentile. Fixed in libvirt 2.5.0-r2.

References

Show 34 moreShow less
MoveEnter Open