Every CVE Search/ Get API key

CVE-2004-0014

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers...

7.5 HighFix available

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Exploit likelihood

2.79%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Record
CVE-2004-0014
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Record
CVE-2004-0014
Updated
2026-11-02
EUVDEUVD-2004-0014 No score

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Record
EUVD-2004-0014
Updated
2026-11-03
GitHub AdvisoriesGHSA-55mw-fq46-6wvv No score

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers...

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Record
GHSA-55mw-fq46-6wvv
Updated
2026-11-02
OSV No score

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Record
CVE-2004-0014
Updated
2026-11-02
OSVDEBIAN-CVE-2004-0014 No score

Multiple buffer overflows in the nd WebDAV interface 0.8.2 and earlier allows remote web servers to execute arbitrary code via certain long strings.

Record
DEBIAN-CVE-2004-0014
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nd
Debian:12
before 0.8.2-1
0.8.2-1
nd
Debian:13
before 0.8.2-1
0.8.2-1
nd
Debian:14
before 0.8.2-1
0.8.2-1
nd
Debian:3.0
before 0.5.0-1woody1
0.5.0-1woody1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2004-0014 is a high vulnerability (CVSS 7.5) in Nd, published January 5, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.79%, the 86th percentile. Fixed in nd 0.8.2-1.

References

MoveEnter Open