Every CVE Search/ Get API key

CVE-2018-1308

There is a XML external entity expansion (XXE) vulnerability in Apache Solr

7.5 HighFix available

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

20.8%Up 17.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
CVE-2018-1308
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
CVE-2018-1308
Updated
2026-11-02
EUVDEUVD-2018-0489 No score

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
EUVD-2018-0489
Updated
2026-11-03
GitHub AdvisoriesGHSA-3pph-2595-cgfh 7.5

There is a XML external entity expansion (XXE) vulnerability in Apache Solr

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
GHSA-3pph-2595-cgfh
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
OSV 7.5

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
CVE-2018-1308
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2018-1308 7.5

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
DEBIAN-CVE-2018-1308
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-3pph-2595-cgfh 7.5

There is a XML external entity expansion (XXE) vulnerability in Apache Solr

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
GHSA-3pph-2595-cgfh
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-611
Updated
2026-11-02
OSVUBUNTU-CVE-2018-1308 7.5

This vulnerability in Apache Solr 1.2 to 6.6.2 and 7.0.0 to 7.2.1 relates to an XML external entity expansion (XXE) in the &dataConfig=<inlinexml> parameter of Solr's DataImportHandler. It can be used as XXE using file/ftp/http protocols in order to read arbitrary local files from the Solr server or the internal network.

Record
UBUNTU-CVE-2018-1308
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVCLSA-2025-1765411676 No score

TuxCare security update for org.apache.lucene (1 CVE)

TuxCare rebuilt 31 org.apache.lucene packages to address 1 CVE. Fixed in 5.5.5-tuxcare.1.

Record
CLSA-2025-1765411676
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.solr:solr-core
Maven
1.2 up to 6.6.3
6.6.3
org.apache.solr:solr-core
Maven
7.0.0 up to 7.3.0
7.3.0
lucene-solr
Debian:12
before 3.6.2+dfsg-12
3.6.2+dfsg-12
lucene-solr
Debian:13
before 3.6.2+dfsg-12
3.6.2+dfsg-12
lucene-solr
Debian:14
before 3.6.2+dfsg-12
3.6.2+dfsg-12
lucene-solr
Debian:7
before 3.6.0+dfsg-1+deb7u4, plus listed versions
3.6.0+dfsg-13.6.0+dfsg-1+deb7u13.6.0+dfsg-1+deb7u23.6.0+dfsg-1+deb7u3
3.6.0+dfsg-1+deb7u4
lucene-solr
Debian:8
before 3.6.2+dfsg-5+deb8u2, plus listed versions
3.6.2+dfsg-53.6.2+dfsg-5+deb8u1
3.6.2+dfsg-5+deb8u2
lucene-solr
Debian:9
before 3.6.2+dfsg-10+deb9u2, plus listed versions
3.6.2+dfsg-103.6.2+dfsg-10+deb9u1
3.6.2+dfsg-10+deb9u2
org.apache.solr:solr-core
Maven
1.2 up to 6.6.3, plus listed versions
1.3.01.4.01.4.13.1.03.2.0
Show 45 moreShow less
3.3.03.4.03.5.03.6.03.6.13.6.24.0.04.0.0-ALPHA4.0.0-BETA4.1.04.10.04.10.14.10.24.10.34.10.44.2.04.2.14.3.04.3.14.4.04.5.04.5.14.6.04.6.14.7.04.7.14.7.24.8.04.8.14.9.04.9.15.0.05.1.05.2.05.2.15.3.05.3.15.3.25.4.05.4.15.5.05.5.15.5.25.5.35.5.4
6.6.3
org.apache.solr:solr-core
Maven
7.0.0 up to 7.3.0, plus listed versions
7.0.17.1.07.2.07.2.1
7.3.0
lucene-solr
Ubuntu:Pro:14.04:LTS
before 3.6.2+dfsg-2ubuntu0.1~esm2, plus listed versions
3.6.2+dfsg-13.6.2+dfsg-23.6.2+dfsg-2ubuntu0.1~esm1
3.6.2+dfsg-2ubuntu0.1~esm2
lucene-solr
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.6.2+dfsg-73.6.2+dfsg-83.6.2+dfsg-8ubuntu0.13.6.2+dfsg-8ubuntu0.1+esm1
None known
lucene-solr
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.6.2+dfsg-103.6.2+dfsg-113.6.2+dfsg-18~18.043.6.2+dfsg-18~18.04.1~esm2
None known

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1308 is a high vulnerability (CVSS 7.5) in Apache Solr, published April 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 20.8%, the 97th percentile. Fixed in org.apache.solr:solr-core 6.6.3.

References

Show 9 moreShow less
This page doesn't list everything

Left out here: 15 versions. The JSON record has them.

MoveEnter Open