Every CVE Search/ Get API key

CVE-2018-18820

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4....

8.1 HighPublic exploitFix available

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

48.9%Up 45.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
CVE-2018-18820
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
CVE-2018-18820
Updated
2026-11-02
EUVDEUVD-2018-10536 No score

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
EUVD-2018-10536
Updated
2026-11-03
GitHub AdvisoriesGHSA-w249-6p6f-4gjq 8.1

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4....

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
GHSA-w249-6p6f-4gjq
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2018-18820 8.1

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
ALPINE-CVE-2018-18820
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 8.1

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
CVE-2018-18820
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
Show 4 moreShow less
OSVDEBIAN-CVE-2018-18820 8.1

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
DEBIAN-CVE-2018-18820
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-18820 8.1

A buffer overflow was discovered in the URL-authentication backend of the Icecast before 2.4.4. If the backend is enabled, then any malicious HTTP client can send a request for that specific resource including a crafted header, leading to denial of service and potentially remote code execution.

Record
UBUNTU-CVE-2018-18820
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0472 No score

Updated icecast packages fix security vulnerability

Buffer overflows in URL auth code if there is a "mount" definition that enables URL authentication. A malicious client could send long HTTP headers, leading to a buffer overflow and potential remote code execution (CVE-2018-18820).

Record
MGASA-2018-0472
Updated
2026-11-02
OSVopenSUSE-SU-2024:10584-1 No score

icecast-2.4.4-2.1 on GA media

These are all security issues fixed in the icecast-2.4.4-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10584-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
icecast
Alpine:v3.10
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.11
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.12
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.13
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.14
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.15
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.16
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.17
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.18
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.19
before 2.4.4-r0
2.4.4-r0
Show 21 moreShow less
Affected packages
PackageAffectedFixed
icecast
Alpine:v3.2
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.20
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.21
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.22
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.23
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.24
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.3
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.4
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.5
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.6
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.7
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.8
before 2.4.4-r0
2.4.4-r0
icecast
Alpine:v3.9
before 2.4.4-r0
2.4.4-r0
icecast2
Debian:12
before 2.4.4-1
2.4.4-1
icecast2
Debian:13
before 2.4.4-1
2.4.4-1
icecast2
Debian:8
before 2.4.0-1.1+deb8u2, plus listed versions
2.4.0-1.12.4.0-1.1+deb8u12.4.0-1.1+deb8u1~bpo70+1
2.4.0-1.1+deb8u2
icecast2
Debian:9
before 2.4.2-1+deb9u1, plus listed versions
2.4.2-1
2.4.2-1+deb9u1
icecast
Mageia:6
before 2.4.4-1.mga6
2.4.4-1.mga6
icecast2
Ubuntu:16.04:LTS
before 2.4.2-1ubuntu0.1, plus listed versions
2.4.2-1
2.4.2-1ubuntu0.1
icecast2
Ubuntu:18.04:LTS
before 2.4.3-2ubuntu0.1, plus listed versions
2.4.3-2
2.4.3-2ubuntu0.1
icecast
openSUSE:Tumbleweed
before 2.4.4-2.1
2.4.4-2.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubimpulsiveness/CVE-2018-188202025-02-02

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-18820 is a high vulnerability (CVSS 8.1) in Xiph Icecast, published November 4, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 48.9%, the 98th percentile. Fixed in icecast 2.4.4-r0.

References

Show 11 moreShow less
MoveEnter Open