CVE-2018-20430
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function...
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
CVE-2018-20430- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
CVE-2018-20430- Updated
- 2026-11-02
EUVDEUVD-2018-12987 No score
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
EUVD-2018-12987- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5hcf-wqrv-xp63
6.5
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function...
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
GHSA-5hcf-wqrv-xp63- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
6.5
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
CVE-2018-20430- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-20430
6.5
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
DEBIAN-CVE-2018-20430- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-20430
6.5
GNU Libextractor through 1.8 has an out-of-bounds read vulnerability in the function history_extract() in plugins/ole2_extractor.c, related to EXTRACTOR_common_convert_to_utf8 in common/convert.c.
- Record
UBUNTU-CVE-2018-20430- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0013 No score
Updated libextractor packages fix security vulnerabilities
Several vulnerabilities were discovered in libextractor which may lead to denial of service or memory disclosure if a malformed OLE file is processed (CVE-2018-20430, CVE-2018-20431).
- Record
MGASA-2019-0013- Updated
- 2026-11-02
OSVUSN-4641-1 No score
libextractor vulnerabilities
It was discovered that Libextractor incorrectly handled zero sample rate. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-15266)
It was discovered that Libextractor incorrectly handled certain FLAC metadata. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-15267)
It was discovered that Libextractor incorrectly handled certain specially crafted files. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-15600, CVE-2018-16430, CVE-2018-20430)
It was discovered that Libextractor incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-15601)
It was discovered that Libextractor incorrectly handled integers. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-15602)
It was discovered that Libextractore incorrectly handled certain crafted files. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-15922)
It was discovered tha Libextractor incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-17440)
It was discovered that Libextractor incorrectly handled certain malformed files. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-14346)
It was discovered that Libextractor incorrectly handled malformed files. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-14347)
It was discovered that Libextractor incorrectly handled metadata. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-20431)
- Record
USN-4641-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libextractorDebian:12 |
before 1:1.8-2 | 1:1.8-2 |
libextractorDebian:13 |
before 1:1.8-2 | 1:1.8-2 |
libextractorDebian:14 |
before 1:1.8-2 | 1:1.8-2 |
libextractorDebian:8 From an advisory covering 2 CVEs |
before 1:1.3-2+deb8u4, plus listed versions 1:1.3-21:1.3-2+deb8u11:1.3-2+deb8u21:1.3-2+deb8u3 |
1:1.3-2+deb8u4 |
libextractorDebian:9 From an advisory covering 2 CVEs |
before 1:1.3-4+deb9u3, plus listed versions 1:1.3-41:1.3-4+deb9u11:1.3-4+deb9u2 |
1:1.3-4+deb9u3 |
libextractorMageia:6 From an advisory covering 2 CVEs |
before 1.7-1.1.mga6 | 1.7-1.1.mga6 |
libextractorUbuntu:Pro:14.04:LTS |
before 1:1.3-1ubuntu0.1~esm1, plus listed versions 1:1.1-1ubuntu11:1.2-1ubuntu11:1.3-1 |
1:1.3-1ubuntu0.1~esm1 |
libextractorUbuntu:16.04:LTS |
before 1:1.3-4+deb9u3build0.16.04.1, plus listed versions 1:1.3-2build11:1.3-2ubuntu11:1.3-3 |
1:1.3-4+deb9u3build0.16.04.1 |
libextractorUbuntu:18.04:LTS |
All versions, plus listed versions 1:1.3-4build31:1.6-11:1.6-1build11:1.6-2 |
None known |
libextractorUbuntu:16.04:LTS From an advisory covering 12 CVEs |
before 1:1.3-4+deb9u3build0.16.04.1, plus listed versions 1:1.3-2build11:1.3-2ubuntu11:1.3-3 |
1:1.3-4+deb9u3build0.16.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-20430 is a medium vulnerability (CVSS 6.5) in Gnu Libextractor, published December 24, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.24%, the 82nd percentile. Fixed in libextractor 1:1.8-2.
References
lists.debian.org/debian-lts-announce/2018/12/msg00015.html
debian.org/security/2018/dsa-4361
gnunet.org/git/libextractor.git/tree/ChangeLog
securityfocus.com/bid/106300
gnunet.org/git/libextractor.git/commit?id=b405d707b36e0654900cba78e89f49779efea110
gnunet.org/bugs/view.php?id=5493
Show 19 moreShow less
nvd.nist.gov/vuln/detail/CVE-2018-20430
github.com/advisories/GHSA-5hcf-wqrv-xp63
security-tracker.debian.org/tracker/CVE-2018-20430
advisories.mageia.org/MGASA-2019-0013.html
bugs.mageia.org/show_bug.cgi?id=24093
ubuntu.com/security/CVE-2018-20430
ubuntu.com/security/notices/USN-4641-1
cve.org/CVERecord?id=CVE-2018-20430
ubuntu.com/security/CVE-2017-15266
ubuntu.com/security/CVE-2017-15267
ubuntu.com/security/CVE-2017-15600
ubuntu.com/security/CVE-2017-15601
ubuntu.com/security/CVE-2017-15602
ubuntu.com/security/CVE-2017-15922
ubuntu.com/security/CVE-2017-17440
ubuntu.com/security/CVE-2018-14346
ubuntu.com/security/CVE-2018-14347
ubuntu.com/security/CVE-2018-16430
ubuntu.com/security/CVE-2018-20431