Every CVE Search/ Get API key

CVE-2019-3466

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges...

7.8 HighFix available

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.50%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
CVE-2019-3466
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-269
Updated
2026-11-02
CVE List No score

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
CVE-2019-3466
Updated
2026-11-02
EUVDEUVD-2019-13104 No score

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
EUVD-2019-13104
Updated
2026-11-03
GitHub AdvisoriesGHSA-rhrq-jx2f-79g7 No score

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges...

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
GHSA-rhrq-jx2f-79g7
Updated
2026-11-02
OSVALPINE-CVE-2019-3466 7.8

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
ALPINE-CVE-2019-3466
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBELL-CVE-2019-3466 7.8

CVE-2019-3466 does not affect BellSoft software

Record
BELL-CVE-2019-3466
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSV 7.8

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
CVE-2019-3466
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-3466 7.8

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
DEBIAN-CVE-2019-3466
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-3466 7.8

The pg_ctlcluster script in postgresql-common in versions prior to 210 didn't drop privileges when creating socket/statistics temporary directories, which could result in local privilege escalation.

Record
UBUNTU-CVE-2019-3466
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4194-1 No score

postgresql-common vulnerability

Rich Mirch discovered that the postgresql-common pg_ctlcluster script incorrectly handled directory creation. A local attacker could possibly use this issue to escalate privileges.

Record
USN-4194-1
Updated
2026-11-02
OSVUSN-4194-2 No score

postgresql-common vulnerability

USN-4194-1 fixed a vulnerability in postgresql-common. This update provides the corresponding update for Ubuntu 14.04 ESM.

Original advisory details:

Rich Mirch discovered that the postgresql-common pg_ctlcluster script incorrectly handled directory creation. A local attacker could possibly use this issue to escalate privileges.

Record
USN-4194-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postgresql-common
Debian:12
before 210
210
postgresql-common
Debian:13
before 210
210
postgresql-common
Debian:14
before 210
210
postgresql-common
Debian:8
before 165+deb8u4, plus listed versions
165165+deb8u1165+deb8u1~bpo7+1165+deb8u2165+deb8u2~bpo7+1165+deb8u3
165+deb8u4
postgresql-common
Debian:9
before 181+deb9u3, plus listed versions
181181+deb9u1181+deb9u1~bpo8+1181+deb9u2
181+deb9u3
postgresql-common
Debian:10
before 200+deb10u3, plus listed versions
200+deb10u1200+deb10u2
200+deb10u3
postgresql-common
Ubuntu:Pro:14.04:LTS
before 154ubuntu1.1+esm1, plus listed versions
148150151152153
Show 4 moreShow less
153bzr1154154ubuntu1154ubuntu1.1
154ubuntu1.1+esm1
postgresql-common
Ubuntu:16.04:LTS
before 173ubuntu0.3, plus listed versions
169git1170171172172ubuntu1173173ubuntu0.1173ubuntu0.2
173ubuntu0.3
postgresql-common
Ubuntu:18.04:LTS
before 190ubuntu0.1, plus listed versions
184ubuntu1188ubuntu1189190
190ubuntu0.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-3466 is a high vulnerability (CVSS 7.8) in Postgresql Postgresql-common, published November 14, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.50%, the 42nd percentile. Fixed in postgresql-common 210.

References

Show 5 moreShow less
MoveEnter Open