CVE-2004-0366
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute...
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute arbitrary SQL statements.
Exploit likelihood
What each source reports
NVD Score used
7.5
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute arbitrary SQL statements.
- Record
CVE-2004-0366- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute arbitrary SQL statements.
- Record
CVE-2004-0366- Updated
- 2026-11-02
EUVDEUVD-2004-0366 No score
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute arbitrary SQL statements.
- Record
EUVD-2004-0366- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-398v-9qw7-49xj No score
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute...
SQL injection vulnerability in the libpam-pgsql library before 0.5.2 allows attackers to execute arbitrary SQL statements.
- Record
GHSA-398v-9qw7-49xj- Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pam-pgsqlDebian:3.0 |
before 0.5.2-3woody2, plus listed versions 0.5.2-3woody1 |
0.5.2-3woody2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2004-0366 is a high vulnerability (CVSS 7.5) in Pam-pgsql, published March 29, 2004. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.47%, the 73rd percentile. Fixed in pam-pgsql 0.5.2-3woody2.