CVE-2019-14380
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2...
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
CVE-2019-14380- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
CVE-2019-14380- Updated
- 2026-11-02
EUVDEUVD-2019-5588 No score
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
EUVD-2019-5588- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g7wp-7x2r-7wgc
6.5
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2...
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
GHSA-g7wp-7x2r-7wgc- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
6.5
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
CVE-2019-14380- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-14380
6.5
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
DEBIAN-CVE-2019-14380- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-14380
6.5
libopenmpt before 0.4.5 allows a crash during playback due to an out-of-bounds read in XM and MT2 files.
- Record
UBUNTU-CVE-2019-14380- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libopenmptDebian:12 |
before 0.4.5-1 | 0.4.5-1 |
libopenmptDebian:13 |
before 0.4.5-1 | 0.4.5-1 |
libopenmptDebian:14 |
before 0.4.5-1 | 0.4.5-1 |
libopenmptDebian:10 From an advisory covering 2 CVEs |
before 0.4.3-1+deb10u1, plus listed versions 0.4.3-1 |
0.4.3-1+deb10u1 |
libopenmptUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 0.2.8760~beta27-10.3.1-10.3.2-10.3.3-10.3.4-10.3.6-10.3.6-1ubuntu0.1~esm10.3.6-1ubuntu0.1~esm2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-14380 is a medium vulnerability (CVSS 6.5) in Openmpt Libopenmpt, published July 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 61st percentile. Fixed in libopenmpt 0.4.5-1.
References
lib.openmpt.org/libopenmpt/2019/05/27/security-update-0.4.5
debian.org/security/2020/dsa-4729
nvd.nist.gov/vuln/detail/CVE-2019-14380
github.com/advisories/GHSA-g7wp-7x2r-7wgc
security-tracker.debian.org/tracker/CVE-2019-14380
ubuntu.com/security/CVE-2019-14380
source.openmpt.org/browse/openmpt/trunk?op=revision&rev=11608
cve.org/CVERecord?id=CVE-2019-14380