Every CVE Search/ Get API key

CVE-2003-0127

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows...

7.2 HighPublic exploitFix available

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows local users to gain root privileges by using ptrace to attach to a child process that is spawned by the kernel.

Exploit likelihood

1.57%Down 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows local users to gain root privileges by using ptrace to attach to a child process that is spawned by the kernel.

Record
CVE-2003-0127
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows local users to gain root privileges by using ptrace to attach to a child process that is spawned by the kernel.

Record
CVE-2003-0127
Updated
2026-11-02
EUVDEUVD-2003-0123 No score

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows local users to gain root privileges by using ptrace to attach to a child process that is spawned by the kernel.

Record
EUVD-2003-0123
Updated
2026-11-03
GitHub AdvisoriesGHSA-jhjp-mfjv-rvhx No score

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows...

The kernel module loader in Linux kernel 2.2.x before 2.2.25, and 2.4.x before 2.4.21, allows local users to gain root privileges by using ptrace to attach to a child process that is spawned by the kernel.

Record
GHSA-jhjp-mfjv-rvhx
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kernel-patch-2.4.17-mips
Debian:3.0
before 2.4.17-0.020226.2.woody1
2.4.17-0.020226.2.woody1
kernel-patch-2.4.19-mips
Debian:3.0
before 2.4.19-0.020911.1.woody1
2.4.19-0.020911.1.woody1
kernel-patch-2.4.17-s390
Debian:3.0
before 0.0.20020816-0.woody.1.1
0.0.20020816-0.woody.1.1
kernel-image-2.4.17-s390
Debian:3.0
before 2.4.17-2.woody.2.2
2.4.17-2.woody.2.2
kernel-source-2.4.18
Debian:3.0
before 2.4.18-9
2.4.18-9
kernel-image-2.4.18-1-i386
Debian:3.0
before 2.4.18-8
2.4.18-8
kernel-image-2.4.18-i386bf
Debian:3.0
before 2.4.18-5woody1., plus listed versions
2.4.18-5
2.4.18-5woody1.
kernel-patch-2.4.18-powerpc
Debian:3.0
before 2.4.18-1woody1
2.4.18-1woody1
kernel-source-2.4.17
Debian:3.0
before 2.4.17-1woody1
2.4.17-1woody1
kernel-patch-2.4.17-mips
Debian:3.0
before 2.4.17-0.020226.2.woody2
2.4.17-0.020226.2.woody2
Show 8 moreShow less
Affected packages
PackageAffectedFixed
kernel-source-2.2.20
Debian:3.0
before 2.2.20-5woody2
2.2.20-5woody2
kernel-image-2.2.20-i386
Debian:3.0
before 2.2.20-5woody3
2.2.20-5woody3
kernel-image-2.4.17-ia64
Debian:3.0
before kernel-image-2.4.17-ia64
kernel-image-2.4.17-ia64
kernel-source-2.4.16
Debian:3.0
before 2.4.16-1woody2
2.4.16-1woody2
kernel-patch-2.4.16-arm
Debian:3.0
before 20040419
20040419
kernel-image-2.4.16-lart
Debian:3.0
before 20040419
20040419
kernel-image-2.4.16-netwinder
Debian:3.0
before 20040419
20040419
kernel-image-2.4.16-riscpc
Debian:3.0
before 20040419
20040419

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2003-0127 is a high vulnerability (CVSS 7.2) in Linux Kernel, published March 18, 2003. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in kernel-patch-2.4.17-mips 2.4.17-0.020226.2.woody1.

References

Show 15 moreShow less
MoveEnter Open